2019 Shield & Kodi 18.5 Start-up issues ?

DanOnly

New member
Jan 14, 2020
5
0
1
I recently upgraded to the Nvidia Shield 2019 Pro. I have a Sony TV, Sony Sound Bar and the newly addition of the shield.

3 addons are installed, everything else is bare bones & defaults, as they were on my previous 2017 Shield Pro. The addons are S*ren, Youtube & Sm***h****ams

Not exactly sure how to describe my issue other than having inconsistent Kodi start-ups. It doesn't matter if I've used either one of those addons for a period of time, after I'm finished, I close the addon, exit Kodi to the Shield main screen and hit the power button to put everything to sleep.

The next day, power everything on, open Kodi, select S*ren, and nothing, only the loading icon appears, but the addon doesn't start. Hit back, try to open Sm***h****ams, or Youtube, I get nothing but the click Kodi default select sound. Many other Kodi features are frozen as well, for instance I cannot add a source in File Manager.

The only way to resolve this is to get back to the Shield menu and select Restart. Which doesn't always seem to remedy the problem after 1, 2 or 3 times even.

I've never had an issue like this before prior to switching to the 2019 Shield. I've factory reset the Shield and Kodi respectively twice, but nothing seems to have made a difference.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,500
48
48
The Halls of Valhalla
Where did you get Kodi from? If it was from the play store, there seems to be some random issues with that version for some reason.
Remove Kodi completely including the profile folder
Restart your Shield
Install Kodi from http://kodi.tv/download/ (be sure to use the 64Bit version for the Shield)
Reinstall your addons

Let me know if that worked for you. I had a similar problems months ago and this fixed it.
 
  • Winner
Reactions: capslock

DanOnly

New member
Jan 14, 2020
5
0
1
Sorry - I should of also asked what is the easiest way of installing Kodi onto the Shield... it's proven to be harder than downloading the apk and transferring it onto a USB and plugging it in
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,500
48
48
The Halls of Valhalla
That is exactly how you do it. Once the USB stick is in the shield, you need to access the thumb drive to execute the installation of Kodi. To do this you will need a file explorer such as "X-Plore file manager" This can be found in the play store.
 
  • Like
Reactions: capslock

DanOnly

New member
Jan 14, 2020
5
0
1
Finally got around to do doing this. No change. Installed Kodi from the website APK 64bit and reinstalled everything and same issue as soon as I closed and reopened Kodi
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,500
48
48
The Halls of Valhalla
You seem to have done everything I would recommend, including factory resetting the shield. Maybe contacting NVidia and see if their customer service can help. Just don't mention any illegal addon you may (or may not) be using.