Addons/Config Wizard Failing to Instal/Launch on ATV4

Jeffryyyy

New member
Dec 25, 2015
9
0
0
So frustrated, trying to Install 1Ch**nel or other Addons and it just says failed check log :mad:
Other Addons from Kodi works but it seems im only having issues with TVADDONS stuff.
I go to select my config wizard, Apple TV, and it just fails and says check log.

XBMC Debug Log Site

someone, please help me!

Merry Christmas!
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,589
59
48
The Halls of Valhalla
Someone said something abut servers a few days ago. Not sure if Git is up or down. Sorry I can't help with the log. Maybe @TKNorris will have a look at it.
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
I had a feeling it was a server issue, ah well I'll just forget about it for a day or two then see what happens.

If anyone else notices anything in the log please let me know it would be much appreciated!
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
so frustrated, I deleted it and reinstalled a differently nightly build and nothing!

I did a fresh start on my iPad to see if there was any installation problems on that and everything works fine! What is going on :mad: :(
 

Blazetamer

New member
Mar 3, 2013
564
0
0
The Yellow Brick Road
kill power completely on the box, power back up, then go straight and try to install an addon via the addon installer, if it errors . STOP RIGHT THERE and go straight and get a new log file, and post it without exiting Kodi or doing anything else until after the log is uploaded.
The first one had too much going on for me to see what the issue may have been.

ALSO DONT USE anything that is not official yet , I noticed your trying 17.0 Alpha Its hard to troubleshoot something that is not complete yet . try 15.2 ish If im not mistaken anything above 15 wont run on ATV anyway


EDIT I STAND CORRECTED, and its worse for you , 14.2 is the last version that is compatible with Apple TV
 
Last edited:

Jeffryyyy

New member
Dec 25, 2015
9
0
0
kill power completely on the box, power back up, then go straight and try to install an addon via the addon installer, if it errors . STOP RIGHT THERE and go straight and get a new log file, and post it without exiting Kodi or doing anything else until after the log is uploaded.
The first one had too much going on for me to see what the issue may have been.

ALSO DONT USE anything that is not official yet , I noticed your trying 17.0 Alpha Its hard to troubleshoot something that is not complete yet . try 15.2 ish If im not mistaken anything above 15 wont run on ATV anyway


EDIT I STAND CORRECTED, and its worse for you , 14.2 is the last version that is compatible with Apple TV
ya Apple TV 4, I assume it eventually will gain support for the newer versions of Kodi. Ok I am getting a log now
 

Blazetamer

New member
Mar 3, 2013
564
0
0
The Yellow Brick Road
if thats the ATV 4 and I assume you are using Xcode to load it , Its a known thing that alot of "our" stuff is being actively blocked by the authors, this could be another of those instances , either way and even if not, 17 is the only thing that is "supposed" to run on the ATV4 and with it being "per,pre,pre alpha release" ( orgs words not mine), there is bunches still broke on it . Still post up that log and we will have a look


BTW here is a c&p from the authors

Known issues:

1. No way to add or change any xml files (like adding addon zips or advancedsettings.xml files)
2. NFS Support is not working atm
3. A dozens more i can't remember right now.
 
Last edited:

Jeffryyyy

New member
Dec 25, 2015
9
0
0
kill power completely on the box, power back up, then go straight and try to install an addon via the addon installer, if it errors . STOP RIGHT THERE and go straight and get a new log file, and post it without exiting Kodi or doing anything else until after the log is uploaded.
The first one had too much going on for me to see what the issue may have been.

ALSO DONT USE anything that is not official yet , I noticed your trying 17.0 Alpha Its hard to troubleshoot something that is not complete yet . try 15.2 ish If im not mistaken anything above 15 wont run on ATV anyway


EDIT I STAND CORRECTED, and its worse for you , 14.2 is the last version that is compatible with Apple TV
Debugging Mode Off: XBMC Debug Log Site
Debugging Mode On: XBMC Debug Log Site

not sure if it makes a difference
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
if thats the ATV 4 and I assume you are using Xcode to load it , Its a known thing that alot of "our" stuff is being actively blocked by the authors, this could be another of those instances , either way and even if not, 17 is the only thing that is "supposed" to run on the ATV4 and with it being "per,pre,pre alpha release" ( orgs words not mine), there is bunches still broke on it . Still post up that log and we will have a look


BTW here is a c&p from the authors

Known issues:

1. No way to add or change any xml files (like adding addon zips or advancedsettings.xml files)
2. NFS Support is not working atm
3. A dozens more i can't remember right now.
Ok I just assumed it was only an issue with be because I assumed there is other people out there trying to do the same thing and I havnt seen anyone having any issues.

not sure what adding or changing xml files means or does, but I assume your implying that may be the issue I'm having =/
 

Blazetamer

New member
Mar 3, 2013
564
0
0
The Yellow Brick Road
Yeah its either still broke, ie: bugs still present, or our installer source location is being actively blocked . cant tell from the log itself, or Im just not seeing it , Your probably gonna have to wait it out until official release .


in the meantime , you may consider getting a Nvidia Shield, those things are wicked awesome ...and FAST to
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
Yeah its either still broke, ie: bugs still present, or our installer source location is being actively blocked . cant tell from the log itself, or Im just not seeing it , Your probably gonna have to wait it out until official release .


in the meantime , you may consider getting a Nvidia Shield, those things are wicked awesome ...and FAST to
Ok thanks mate! I can rest easy for now.
An official release of Kodi is what you mean right?

As for the Nvidia shield ive heard great things! But am currently stuck in and loving the Apple ecosystem :eek: ill just have to wait.
Just the other day I tried Hulu for the first time and im loving that, it should hold me over until an official release!
 

Blazetamer

New member
Mar 3, 2013
564
0
0
The Yellow Brick Road
Yeah Official 17.0 for the ATV4 in particular Im sure it will be a while , I am all about apple too, but DUDE....after the Shield, I will NEVER try an ATV again, they are ok but , DAM the shield is a beast. Thanks for joining the forum. Rest well
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
Yeah Official 17.0 for the ATV4 in particular Im sure it will be a while , I am all about apple too, but DUDE....after the Shield, I will NEVER try an ATV again, they are ok but , DAM the shield is a beast. Thanks for joining the forum. Rest well
Hey! I got 1Ch**nel and Genesis working through a different repo/source! Thanks for your help for now, really would love Config Wizard.

One issue tho with both, any idea what could be causing every source to play the media all choppy?

Imgur: The most awesome images on the Internet
 

Jeffryyyy

New member
Dec 25, 2015
9
0
0
PM me the source/repo that you used so I can confirm if blocking is the problem.

The "chop" is probably just "growing pains" on the alpha builds for the ATV4
I used "http://iwillfolo.com/iwf/" for Genesis
And for 1Ch**nel I cant quite remember but it was somewhere from ********* "http://srp.nu" repositories

Regarding the choppiness, its just odd because video addons from Kodi official repo work fine =/