AppleTV IR remote config for xbmc-linux on Pivos/MyGica/Sumvision etc

Nukeybrown

New member
May 13, 2012
330
0
0
output on only pressing centre button

login as: root
[email protected]'s password:
[[email protected] /root]# dmesg | tail
[ 179.801407] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 179.947150] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[ 180.012967] scancode is 0x005c, invalid key is 0x0000.
[ 180.117975] scancode is 0x005c, invalid key is 0x0000.
[ 180.118034] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 180.267145] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[ 180.336724] scancode is 0x005c, invalid key is 0x0000.
[ 180.441747] scancode is 0x005c, invalid key is 0x0000.
[ 180.441805] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 180.597153] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[[email protected] /root]#
 

geeksquad

New member
Jan 4, 2013
89
0
0
redownload the atv.conf, I've made some changes to make it work with both possible apple codes (I think)
 

Nukeybrown

New member
May 13, 2012
330
0
0
strange, all directional buttons but still no centre button.

you do mean just wget the same link from the first page yes?
 

Nukeybrown

New member
May 13, 2012
330
0
0
same output from centre button

login as: root
[email protected]'s password:
[[email protected] /root]# dmesg | tail
[ 182.948528] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 183.079613] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[ 183.080258] scancode is 0x005c, invalid key is 0x0000.
[ 183.184604] scancode is 0x005c, invalid key is 0x0000.
[ 183.184670] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 183.304424] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[ 183.305070] scancode is 0x005c, invalid key is 0x0000.
[ 183.409471] scancode is 0x005c, invalid key is 0x0000.
[ 183.409539] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 183.557141] fcode map = 0 release ircode = 0x05, scancode = 0x0019
[[email protected] /root]#
 

Nukeybrown

New member
May 13, 2012
330
0
0
Only button press that doesnt seem to work after testing is long press on menu button on apple tv gave options on screen , like if you type the wrong addon http address i. You could hold menu button in to get delete option , also you could hold menu on addon repo to check updates that kind of thing , the original remote had a seperate button on , not sure how easy that would be to map to a long press on menu
 
Last edited:

geeksquad

New member
Jan 4, 2013
89
0
0
Not sure if long press is going to be straightforward, remind me about it after I get the wifi working ;)
 

Nukeybrown

New member
May 13, 2012
330
0
0
will do , also the onscreen keyboard when you type in it , it puts a P after ever letter you type lol so 1p 2p 3p 4 . volume up n down in video is acting like ffw and rewind lol . will remind ya , wifi is more important
 

Smith Online

New member
Jan 30, 2013
33
0
0
England (UK)
Hi,
Firstly thanks geeksquad for your great work :)

I have an issue with atv remote it works all arrows menu button and play/pause all work fine issue is with center button and its a strange one.
I just purchased the atv remote new today model of remote is a1294 aluminium one.

The problem i have got is that when i press center button to click on videos with atv remote it takes a moment then loads a random video from library its like the center button has been set with more the one command if you know what i mean. if i use original cyclone nano M3 remote works fine and plugged in usb keyboard works fine the fault only happens with atv remote??

can do a video to better explain if you need

Happy to help any way i can

Thanks in advance
Regards
Smith Online
 

geeksquad

New member
Jan 4, 2013
89
0
0
@Nukey: Up and down are supposed to do that by default I think. regarding the P appearing in keyboard, mine doesn't do that, I'll see if i can work out why.


@Smith
ok, thats interesting :)

Need you to ssh into your box and run
Code:
dmesg | tail
after pressing the centre button to see what is happening.
 

geeksquad

New member
Jan 4, 2013
89
0
0
@Nukey Long presses do work, Can you let me know what you expect to work on long press.


Long press of menu button brings you back to the home screen
 

Nukeybrown

New member
May 13, 2012
330
0
0
On apple tv if you long press on menu button lets say an addon it gives you addon settings menu etc. long press on repo gives you check for updates and long press on file manager menu gives you copy file etc. this one just acts like you have pressed back button
 

Smith Online

New member
Jan 30, 2013
33
0
0
England (UK)
@Smith
ok, thats interesting :)

Need you to ssh into your box and run
Code:
dmesg | tail
after pressing the centre button to see what is happening.
Hi, ok clicked center button on remote on the videos option it loaded a random video as usual here is output of dmesg | tail

login as: root
[email protected]'s password:
[[email protected] /root]# dmesg | tail
[ 18.304055] osd0=>x:0 ,y:0,w:1280,h:720
[ 18.304059] osd1=> x:0,y:0,w:0,h:0
[ 19.857174] Headphone unpluged
[ 19.887082] eth0: no IPv6 routers present
[ 130.469044] fcode map = 0 press ircode = 0x03, scancode = 0x000e
[ 130.737148] fcode map = 0 release ircode = 0x03, scancode = 0x000e
[ 133.984165] fcode map = 0 press ircode = 0x5c, scancode = 0x001c
[ 134.089048] fcode map = 0 release ircode = 0x5c, scancode = 0x001c
[ 134.089719] fcode map = 0 press ircode = 0x05, scancode = 0x0019
[ 134.237139] fcode map = 0 release ircode = 0x05, scancode = 0x0019

I think this is related to the p being adding to the end of everything pressed when pressing center button like @Nukeybrown mentioned as mine adds the p aswell.

Yeah the long press of center button i think would be the only other option to add if possible to remote.
when you press and hold center button say on a video source it would bring up menu to delete source / update library etc.

Thanks
Regards,
Smith Online
 
Last edited:

geeksquad

New member
Jan 4, 2013
89
0
0
ok, I have updated atv.conf to work with both aluminium remote codesets, please re-download and test.

The white remote won't work with the same conf file, so you will need atvwhite.conf for that one.

Fingers crossed this time ;)

I'll look at the long press for the centre button mapping to context menu later.
 

dogsballs

New member
Jan 29, 2013
69
0
0
im a bit confused now as i cant see anywhere an atvwhite.conf but i have seen thankfully that the mygica a11 remote has been mapped. so that you geeksquad for that, will report back when i actually get the unit
 

geeksquad

New member
Jan 4, 2013
89
0
0
im a bit confused now as i cant see anywhere an atvwhite.conf but i have seen thankfully that the mygica a11 remote has been mapped. so that you geeksquad for that, will report back when i actually get the unit
Details were on a post on page 3, have updated the first post with the details :)
 

Nukeybrown

New member
May 13, 2012
330
0
0
Not putting a p after everything. See if i can explain this. On the apple tv when your in videos - addons, say you move to 1Ch**nel , youmcan press menu and keep hold of it and it brings up the addon settings , addon information, check for update. On this one when you press menu in addons it acts as a back button which it is but on a long press acts like a menu button , on the 510b remote it has a seperate button for menu which is between the back button and the home button on the remote. This is needed when you have an addon that say you need to out the username and password in. The long way to do it is to go into settings , addons , addon repo then to the addon and config.
 

Smith Online

New member
Jan 30, 2013
33
0
0
England (UK)
ok, I have updated atv.conf to work with both aluminium remote codesets, please re-download and test.

Fingers crossed this time ;)

I'll look at the long press for the centre button mapping to context menu later.
Hi,
Spot on hit the nail on the head mate works perfect no issues no random videos loading anymore and no p appearing anymore Perfect!

Just the hold center button for context menu when you get time mate then atv.conf will be complete.

Thanks alot :)

Regards,
Smith Online
 

Nukeybrown

New member
May 13, 2012
330
0
0
Think the remote not acting like apple tv is due to the joystick.appleremote.xml file as looking around this has a lot more settings relating to the buttons acting differently depending in what part of xbmc you are in e.g playing a video or browsing addons or saving to favourites etc. just a thought