autostart.sh mount points not working since April 11 build

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
Hi

Here is my autostart.sh code:
Code:
#!/bin/sh
(sleep 30; \
mount -t cifs -o username=guest,rw //192.168.1.111/hdd_a/Movies/ /storage/nasfolder; \
)&
which works perfectly until builds after April 11th. Then I get nothing. I'm baffled by this as I can't see anything in the code that is wrong and I know some of you guys use mount points in later builds. Any ideas????
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Hi

Here is my autostart.sh code:
Code:
#!/bin/sh
(sleep 30; \
mount -t cifs -o username=guest,rw //192.168.1.111/hdd_a/Movies/ /storage/nasfolder; \
)&
which works perfectly until builds after April 11th. Then I get nothing. I'm baffled by this as I can't see anything in the code that is wrong and I know some of you guys use mount points in later builds. Any ideas????
Thats odd, try ssh in and execute:
mount -t cifs -o username=guest,rw //192.168.1.111/hdd_a/Movies/ /storage/nasfolder

To see what kinda error you get. Server changed ip? Access? Make sure /storage/nasfolder exist. Heh
Anyway the command should give you some kinda hint on what's going on.
 
Last edited:

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
I'll update a backup build and have a go to see what the error is. I can update to a new build and see its not mounted and then revert back and it's fine so I know it's not a setting in the file that's wrong
 

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
Hi tuxen

Did you manage to figure it out? I'd love to get a newer build on so I can get up to 12.2 but I need my NAS mounted.

Anyone else got any ideas as to why builds after April 11th don't mount my NAS? See OP
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
@bullsboy just tried the command through ssh, and it works absolutely fine here!

Command I used:
Code:
mount -t cifs -o username=XBMC,password=******,rw //192.168.0.102/system /storage/mnt
That's openELEC 3.1.1 the only difference is I have a password. Have you tried typing the line instead of copy/paste or visa versa? Make sure its 100% correct because the error you get from mount makes no sense. I even tried mounting it including a subdirectory under the mount point like you do:
Code:
mount -t cifs -o username=XBMC,password=******,rw //192.168.0.102/system/[B]temp[/B] /storage/mnt
Works fine..
One other thing I noticed, you have a trailing / after the share that is not really supposed to be there. Although it should make no difference at all.

Edit: just tried a dev build, and it also works?! As you I'm baffled to, I used it a loong time after april in my autostart.sh until I finally moved my data.
The reason I want you to type it in ssh is to get a proper error message, because it could be something simple like if your network is not up in 30secs on never builds. 30secs is the timeout of the script.
 
Last edited:

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
I'm going to have a play tomorrow. The only things I can think is that there has to be a password, it's the trailing slash or I can try a different NAS drive.

I'll keep you posted
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Hmm it doesn't look that way because if I execute it without the password like you, the mount command responds properly with "permission denied"

But yeah the right way is to setup a XBMC user with a password on the NAS. But that's only for your own security reasons. Neverless it won't hurt to try.
 
Last edited:

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
May have had a breakthrough. I need to go and try it but it looks like kernel 3.8 introduced something that I need to fix

apparently I need to add sec=ntlm into the -o options

Hope this works!!!!
 

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
BINGO!

Turns out my ancient NAS needed to use ntlm authentication

Code:
mount -t cifs -o sec=ntlm,username=guest,rw //192.168.1.111/hdd_a/Movies/ /storage/nasfolder
Works!