Common revolvers in URLresolver that are not working.

s7eele

Member
Sep 29, 2012
427
0
16
US of A (Deep Deep South)
More Info on 180Upload, not sure if it is useful or not

@tk - I know your already working the issues, specifically 180Uploads, but I wanted to share one more thing that might be useful, might not. I may be expecting too much. Certainly not looking for any help troubleshooting or fixing, I am more than happy to wait for you to release a version that is fixed. You may have done so already, I had to do a factory reset and haven't gotten back up and running yet. To clarify on my previous post regarding lock ups when trying to use 180Uploads. In add-ons it was still locking up most of the time but I was given an opportunity to enter a captcha, or two, or three (lol). Anyway, I was also using an add-on, one that uses 180Uploads, to add shows to my library and when trying to play one through my library and selecting 180Upload I am never prompted to enter a captcha. This may be normal behavior. It would be nice to know whether to expect problems caused by sites using captcha after adding files to your library through an add-on.

Thanks for everything! :eek:
 

tknorris

New member
Feb 18, 2014
201
0
0
@tk - I know your already working the issues, specifically 180Uploads, but I wanted to share one more thing that might be useful, might not. I may be expecting too much. Certainly not looking for any help troubleshooting or fixing, I am more than happy to wait for you to release a version that is fixed. You may have done so already, I had to do a factory reset and haven't gotten back up and running yet. To clarify on my previous post regarding lock ups when trying to use 180Uploads. In add-ons it was still locking up most of the time but I was given an opportunity to enter a captcha, or two, or three (lol). Anyway, I was also using an add-on, one that uses 180Uploads, to add shows to my library and when trying to play one through my library and selecting 180Upload I am never prompted to enter a captcha. This may be normal behavior. It would be nice to know whether to expect problems caused by sites using captcha after adding files to your library through an add-on.

Thanks for everything! :eek:
180uploads (and the other HD sources like it) locking up issues should be resolved in the next release of urlresolver. The current beta release has fixed it. Someone else also submitted an update to the 180upload resolver to try the embedded link first as apparently sometimes that doesn't trigger a captcha check. That might be what that other addon is doing.

Also, it's probably worth mentioning that I don't own urlresolver, Eldorado does. So, he decides when to do new releases and stuff. I just submit fixes for resolver plugins when i notice they are broken.
 

lowridin_guy

New member
May 10, 2012
339
0
0
Just want to pop in and say thanks to those who submit fixes for this. This is a VERY important aspect of XBMC and I'm happy to see people with knowledge pitching in and helping out.

Hopefully we can get another official update pushed out.
 

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
It's coming just taking time to review fixes and push them out as beta's... which is a necessary step as we've had issues before with bad releases before being tested by a number of users/devs

It seemed like I was ready for a release last week but then got some more worthwhile fixes in.. I'll put a hard line down on what I currently have and try to get it out by end of the weekend or very early next week
 

s7eele

Member
Sep 29, 2012
427
0
16
US of A (Deep Deep South)
180uploads (and the other HD sources like it) locking up issues should be resolved in the next release of urlresolver. The current beta release has fixed it. Someone else also submitted an update to the 180upload resolver to try the embedded link first as apparently sometimes that doesn't trigger a captcha check. That might be what that other addon is doing.

Also, it's probably worth mentioning that I don't own urlresolver, Eldorado does. So, he decides when to do new releases and stuff. I just submit fixes for resolver plugins when i notice they are broken.
Understood, I think I knew that bit about Eldorado but now I know for sure. Appreciate your responsiveness as usual. I was running the beta versions of the resolver for a bit but I stopped, not even real sure why. Oh yeah, I got an Ouya on the cheap and I've been using it with the standard module. Hope I get the lingo right there. So grateful to all of the folks that have a hand in making this site what it is, no doubt it has been instrumental in creating a very active Kodi community and that's awesome.

It's coming just taking time to review fixes and push them out as beta's... which is a necessary step as we've had issues before with bad releases before being tested by a number of users/devs

It seemed like I was ready for a release last week but then got some more worthwhile fixes in.. I'll put a hard line down on what I currently have and try to get it out by end of the weekend or very early next week
Thanks for the update and please don't take anything I said as being unsatisfied in any way. I was just providing input I thought might help in the diagnosis or resolution proccess. Honestly, I don't know how the 'collective you' keep things as up to date as you do, it's a tall order. Looking forward to the update and thanks again.
 

samu-rai

New member
Nov 15, 2013
14
0
0
I don't know if you guys are aware already, but firedrive have introduced ads at the start of video playback.
 

samu-rai

New member
Nov 15, 2013
14
0
0
I've started having sporadic resolver failures on videos that I know are defiantly there. Having looked on the site, the only think I can see that is different is the video ads that you have to skip after 10 seconds to get to the video.
 

lowridin_guy

New member
May 10, 2012
339
0
0
Just wondering if there was a way to check to see what version of URLresolver I have installed.

I was just wondering if the new version got pushed out already.
 

invisable

New member
Feb 23, 2013
767
0
0
UK
Just wondering if there was a way to check to see what version of URLresolver I have installed.

I was just wondering if the new version got pushed out already.
I remember I got a update last week it's in the official xbmc repo and its also on Eldorados repo as it's his, work of art

The only reason I know mine is updated as I'm using helix alpha 1 so I have to allow all updates, otherwise I wouldn't know. Modules will not show up in repos & Gotham auto updates.

If your worried I suppose you could use tvaddon maintenance tool and under genral maintenance> check modules> then remove and reinstall urlresolver from the source. However don't think there is any need.

To check the version the only way I know is to look at the xml files for it.
 

tknorris

New member
Feb 18, 2014
201
0
0
Just wondering if there was a way to check to see what version of URLresolver I have installed.

I was just wondering if the new version got pushed out already.
The easiest two ways to check are
1) To check your log. Anytime urlresolver is loaded, it prints out the current version that is installed.
2) Open .xbmc/addons/script.module.urlresolver/addon.xml and look for the version information in that file.
 

bdam

New member
Jul 29, 2013
7
0
0
I'll take a closer look if I get a chance but trying to resolve the Pri**wire URLs for the last episode of season 2 for Orange is the New Black reveals a few plugins that don't seem to work:

vidbull: Returns a long string instead of a url.
sharerepo: Returns 'Video Not Found' despite it being there.
filenuke: Returns 'File Not Found or removed' despite it being there.
 

tknorris

New member
Feb 18, 2014
201
0
0
I'll take a closer look if I get a chance but trying to resolve the Pri**wire URLs for the last episode of season 2 for Orange is the New Black reveals a few plugins that don't seem to work:

vidbull: Returns a long string instead of a url.
sharerepo: Returns 'Video Not Found' despite it being there.
filenuke: Returns 'File Not Found or removed' despite it being there.
FYI, There's a fix already pending for vidbull that requires a new library dependency.
 

s7eele

Member
Sep 29, 2012
427
0
16
US of A (Deep Deep South)
Update - it seems premiumize.me has created a customer ID and PIN dataset that is now to be used in place of the previous username/password combination. No way to test right now but will ASAP and report back.

Original message -

Greets all, looking for some quick input. I am currently testing Premiumize.me and just recently started having issues. When I logged into premiumize to check on their end it turns out they have made some changes including a new website. So my quick and hopefully easy question is:

Has there been any work done on urlresolver in relation to these recent changes on their end?

In this scenario, finding out nothing needed to be done would be considered 'work'.

I've only had time to do a little digging into premiumize and I'm not finding the stats page and there are other things bothering me as well. I most certainly need to take action with premiumize but wanted to ask the question above first.

Thanks!
 
Last edited:

s7eele

Member
Sep 29, 2012
427
0
16
US of A (Deep Deep South)
Update -

This involves the changes recently implemented at premiumize.me and the questions I've asked about it in earlier posts in this thread. I finally logged into the Kodi forums and posted in the urlresolver thread there. No solution yet but Eldorado, at least, is aware of it. I will be following it in the Kodi forums urlresolver thread from now on. Leaving this here for anyone who might come looking.

Original message -

Any information available regarding premiumize.me and recent changes they have implemented?

I am going to search for the 'right' thread but if anyone could point me to it I would sincerely appreciate the help.

Thanks!
 
Last edited:

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
Will likely get more traction here, I don't have a premiumize account so will need a dev with one to help fix this resolver
 

s7eele

Member
Sep 29, 2012
427
0
16
US of A (Deep Deep South)
Thanks friend, I've been gone for a while recovering from surgery. Unfortunately, my premiumize.me account has expired. I still have a lot of catching up to do but I have yet to see an answer or fix regarding premiumize.me. I will be renewing my premiumize.me account at least one more time and would really like to see it working with Kodi. They offer some unique things that do not appear to be offered by their competitors, the major ones at least. Thanks again for your responsiveness and let me know if you guys ever need someone to help in testing premiumize.me.