do i need new box

mkdon

New member
Aug 7, 2014
8
0
0
hi guys

i got a m8 android box and using kodi 16.1. i know i cant get 17 due to my system being a little old however this morning i got a message when i went onto kodi saying i must have 17 as all older versions will stop working. is this true? i only use mine to watch champions league football. do i need to get a newer box or am i ok using my box
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,661
75
48
The Halls of Valhalla
You will be OK as long as it works. Keep in mind that you will eventually have to replace it. However, there are alternatives. You could load up LibreElec on it. That will move it to a Linux dedicated to Kodi. Or use FTMC which will also make it usable for the newest Kodi.

But all that only when you finally can't use yours as an Android anymore.
 

skyhigh

Member
Jan 11, 2015
62
1
8
I don't see any reason to dump 16.1 other than you cant a few https streams, but you could always run FTMC and have the best of both worlds..
 

Meep

New member
Aug 23, 2016
692
0
0
I don't see any reason to dump 16.1 other than you cant a few https streams
There are some addons that already are useless without the upgrade to 17.x, and in the coming months that 'few' https streams is going to grow, in fact for many steaming addons like Ex**us the difference between the 16.1 results and and 17.1 results even now can be quite varied for some shows and movies...
 
Last edited:

kdnoel

New member
Sep 4, 2013
115
0
0
North Carolina
I've moved on to the Mi Box for $70 and am happy to have a supported Google TV o/s for future support.
Doesn't get much better for the money.
 

Chadman

New member
Oct 12, 2014
262
0
0
FTMC lists as 16.1. Is there a 17.1 version or does it support the features of 17.1?
 

Meep

New member
Aug 23, 2016
692
0
0
FTMC lists as 16.1. Is there a 17.1 version or does it support the features of 17.1?
FTMC has a newer version of Python bundled with it, so it will support newer https TLS v1.2 links... But, beyond that it is very much 16.1 and doesn't have the full benefits/changes of 17.1...
 

Chadman

New member
Oct 12, 2014
262
0
0
So as long as the addon doesn't require 17 to actually run, it's good to go? Nice. Thanks for the heads up
 

Meep

New member
Aug 23, 2016
692
0
0
So as long as the addon doesn't require 17 to actually run, it's good to go? Nice. Thanks for the heads up
Yes, FTMC should work AOK for addons developed and designed to work on Kodi 16, but as new addons come out that take advantage of new features of Kodi 17 and beyond FTMC will come up short...

Another option is to abandon Android and flash the box with a proprietary version of Linux/Kodi like LibreELEC that will allow it to fully support Kodi 17, but this is a little more tricky vs just installing FTMC...
 

zemelya

New member
Aug 6, 2015
51
0
0
How is KODI 17 running on your MI BOX? Ex**us specifically, if you are using it. I thought it would run smoothly but there is something weird going, almost every addon's streams are keep buffering, even SD. I like the box, internet is good, WI_FI connection seem good, downloaded KODI in minutes, all setup went flawless but it's just something not right, can't pinpoint the issue, unfortunately. Not much details here, I know but in general does it run as good as KODI 16?
 

kdnoel

New member
Sep 4, 2013
115
0
0
North Carolina
I'm currently running SPMC and do use Ex**us. SPMC gives me voice search with the remote is the main reason I use it.
I haven't had any real problems with buffering related to the Mi Box.
I'm curious as to why you would be having problems. I can't understand why it would be something tied to the hardware unless it is the WiFi.
I wish I had more to add but mine works well.

How is KODI 17 running on your MI BOX? Ex**us specifically, if you are using it. I thought it would run smoothly but there is something weird going, almost every addon's streams are keep buffering, even SD. I like the box, internet is good, WI_FI connection seem good, downloaded KODI in minutes, all setup went flawless but it's just something not right, can't pinpoint the issue, unfortunately. Not much details here, I know but in general does it run as good as KODI 16?