Fire tv stick keeps crashing when watching a movie.

DankNasty

New member
May 16, 2012
120
0
0
I've noticed that about 20 minutes into a movie using both genesis and 1Ch**nel xbmc will crash and take me back to the main amazon screen. This happens without fail on the new hunger games stream from the source "streamin". And only on my stick not on my fire tv, I have tested both.
 

DankNasty

New member
May 16, 2012
120
0
0
You posted pretty much the same thing here http://forums.tvaddons.co/threads/30212-Genesis-constantly-crashing-mid-movie-on-my-fire-stick?p=254783#post254783

Please keep to one thread

And also,you need to give at least some info,nobody can have any clue as to what you setup etc is

HAve you got any advancesettings?

Have you tried changing the hardware accelaration options? etc
Ok well this just recently started happening before now I have been streaming fine the only change that I can think of is the new amazon update. I am using the latest version of spmc and have tried going to kodi and a later version of spmc the issue remains. I do have an advanced setting which is buffermode 0, cachemembuffesize 419430400, and readbufferfactor 20

Could this advanced settings be causing it to crash?
 

mj71

New member
Jan 13, 2013
3,706
0
0
I would try it without the settings and see what happens (you can always add it back later if you want)

This way you can maybe eliminate at least one possible cause,then if it plays ok without you could maybe tweak the settings (or do away with them if not needed)
 

DankNasty

New member
May 16, 2012
120
0
0
I would try it without the settings and see what happens (you can always add it back later if you want)

This way you can maybe eliminate at least one possible cause,then if it plays ok without you could maybe tweak the settings (or do away with them if not needed)
Yea they are advanced settings I use on my fire tv's that work great, I wish I had a better understand of what each function does but I believe it is using the devices memory to buffer the videos instead of the local storage. So I guess with the stick having half memory this might be the root of the problem let me test and see.
 

mj71

New member
Jan 13, 2013
3,706
0
0
This might help give you a better insight
Code:
http://kodi.wiki/view/HOW-TO:Modify_the_video_cache
 

crawl

New member
May 7, 2012
147
0
0
Kansas City, MO
Ok well this just recently started happening before now I have been streaming fine the only change that I can think of is the new amazon update. I am using the latest version of spmc and have tried going to kodi and a later version of spmc the issue remains. I do have an advanced setting which is buffermode 0, cachemembuffesize 419430400, and readbufferfactor 20

Could this advanced settings be causing it to crash?
Maybe. That equates to ~420MB of RAM. Which if you check the link that mj71 posted that explains cachemembuffersize, it requires that you have double that amount of free RAM available. Which would be ~840MB of RAM. FireTV Stick has 1GB of RAM. So you're dedicating ~840MB of RAM to cache, which would only leave ~160MB of system RAM for use by FireOS and XBMC. I could see how that setup could crap itself once the cache fills all the way.

As has been recommended, I'd remove the advancedsettings file and retest. If that proves to be the culprit, use a smaller cachemembuffersize value.
 

DankNasty

New member
May 16, 2012
120
0
0
Yup I deleted advanced settings off the stick and all is good now. Do you think these settings are decent for the standard ftv. I've been running it fine just would like to avoid this problem again if I can.
 

splatee

New member
Aug 28, 2013
82
0
0
@ DankNasty.....

Here are what i am using for my advanced settings on Fire TV Stick...

<advancedsettings>
<network>
<buffermode>0</buffermode>
<cachemembuffersize>52428800</cachemembuffersize>
<readbufferfactor>10</readbufferfactor>
</network>
</advancedsettings>

With my Fire TV Stick Kodi shows free memory of around 180MB. So i have cache buffer size set to 50MB, so there is still plenty of memory left.

Thank you
 

filletboy

New member
Nov 27, 2012
504
0
0
Mass, US
I would try it without the settings and see what happens (you can always add it back later if you want)

This way you can maybe eliminate at least one possible cause,then if it plays ok without you could maybe tweak the settings (or do away with them if not needed)
if he already added settings, how would you go about "do away with them" ???
 

mj71

New member
Jan 13, 2013
3,706
0
0
if he already added settings, how would you go about "do away with them" ???
What do you mean :confused:

If it runs fine without the settings (like he just tried),then dont add them back i.e do away with them,dont use them,dont put them back,they arent needed,get rid of them

Or if he still wants to use some settings,they obviously need tweaking
 
Last edited:

filletboy

New member
Nov 27, 2012
504
0
0
Mass, US
What do you mean :confused:

If it runs fine without the settings (like he just tried),then dont add them back i.e do away with them,dont use them,dont put them back,they arent needed,get rid of them

Or if he still wants to use some settings,they obviously need tweaking
That is what i was asking because the statement was to "do away with them".
In order to "do away" with a setting is IF the setting was already added lololol

And I believe the op already added the setting (not sure-will go look)?
 

mj71

New member
Jan 13, 2013
3,706
0
0
I really have no clue as to why this is so confusing for you to understand.The op did have advancedsettings,he then tried it without and it works.What is confusing you?
 

filletboy

New member
Nov 27, 2012
504
0
0
Mass, US
He deleted them!!! You keep saying the same thing over and over lol. What dont you understand?

I give up
very cute
Thats my point
i was un aware that you could delete a setting such as cache settings
of course maybe with a fresh start?
Sorry, didn't know a basic question would get you slamming your head on a wall lololol
 

mj71

New member
Jan 13, 2013
3,706
0
0
very cute
Thats my point
i was un aware that you could delete a setting such as cache settings
of course maybe with a fresh start?
Sorry, didn't know a basic question would get you slamming your head on a wall lololol
The question didnt cause me to bang my head on a wall,the constant repetitiveness of asking the same thing over and over was what did it lol

If you wanted to ask a "basic question" then you should have asked that question in the first place instead of some crazy convoluted way of getting there

Now,you finally make sense.
All you had to do was ask"how do i delete advanced settings",then you could have had your answer right away instead of running round in circles and tying the question up in another topic

Im happy to help if you just asked the question :)

So...the answer is yes you can add and remove any part or all of the advancedsettings anytime you want.You can do this by using the maintenance tool where it says "remove advancedsettings"

Or you could use kinkins easy settings addon

Or you could edit the xml on your computer for example or delete it alltogether,its up to you

Hope this finally makes sense to you now
 
Last edited:

filletboy

New member
Nov 27, 2012
504
0
0
Mass, US
OK
just found the "Remove Advanced Settings" tab in Maint

My bad
*finds baseball bat an slams head* lololol
Never noticed this
 

Leilan

New member
Feb 22, 2015
50
0
0
I connect my fire tv stick to one tv (Sharp Aquos LC60LE640U)and my streams stop after just minutes. I connect to my other Tv ( Affinity LE3251) and streams are flawless. I also run Kodi on my tablet/PC and no issues. I've installed Kodi on many fire tv sticks for others and they have no issue. On all devices, I've used config wizard and am running the defaults according to which device. My question is, why would my fire stick work on one TV with the same settings and not work on another? Not sure if this is relevant, but on the Sharp TV I switched the power outlet that I plugged the AC adapter into and that fixed it for about a week, then back to the same. This tv is also closer to my router so the signal as far as I know is not the issue. Does anyone know why this would be?
 

ThomMerlin

New member
Jul 23, 2015
1
0
0
Power Issue with Certain TV USB power outputs

I connect my fire tv stick to one tv (Sharp Aquos LC60LE640U)and my streams stop after just minutes. I connect to my other Tv ( Affinity LE3251) and streams are flawless. I also run Kodi on my tablet/PC and no issues. I've installed Kodi on many fire tv sticks for others and they have no issue. On all devices, I've used config wizard and am running the defaults according to which device. My question is, why would my fire stick work on one TV with the same settings and not work on another? Not sure if this is relevant, but on the Sharp TV I switched the power outlet that I plugged the AC adapter into and that fixed it for about a week, then back to the same. This tv is also closer to my router so the signal as far as I know is not the issue. Does anyone know why this would be?
Not all TV's have the same power output for the USB port. Some newer, and I do mean NEWER TV's made in the last 1 year or so have the possibility to handle of power output of 5W/1A, which is what the TV stick requires. However, you will not know this unless you look on the surrounding area around the USB Port on the TV itself to see if it indicates what the power output is. If it doesn't, then consult your owners manual that came with your TV, or just look up your TV model online and look for USB Port Power output.