FTV no sound on a/v receiver

rosario04

New member
Dec 31, 2016
5
0
0
Ok. Here it goes. Kodi on Firestick with krypton 17 Rc2. Skin is aeon nox 5 (v-5.9.8.). Tv 1 has simple aux 3.5 mm port for sound. Sound works.

Tv 2 connected with a simple a/v receiver...firestick plugged in to hdmi port on tv in the arc port then connect to HDMI port in a/v receiver. Tv has 4 hdmi ports with one of them arc. Sound works.

Tv 3 connected to new sony a/v receiver....firestick connected to hdmi port on tv and arc cable going to arc port on a/v receiver.
No sound.

Firestick is the new one that just came out with the voice recognition remote. Here is what I've tried after combing thru the internet with no success on Tv 3??

Any help would be greatly appreciated. Thanks

For the sound:

First thing unplug the stick from the back of the tv and then unplug power to the sick. Shut tv off and unplug power. Leave both off for 10 to 15 seconds. Plug tv in and select your input source where you want to connect your stick to HDMI 1, 2 or 3... Now plug in the HDMI end of the stick and plug it in to the HDMI input you selected and lastly plug it into the outlet. Wait until the stick loads up and shows the Amazon menu. See if sound came back, if not then connect the HDMI end of the stick to another HDMI port and don't forget to select that input in your tv. If still no sound then unplug stick from power and unplug power to the tv and reconnect them and try it again.
If still is a problem leave everything as you last set it up and follow the bottom troubleshooting (stay in the Amazon Menu):

1. Dolby Settings

⦁ Settings Display & Sounds Audio
⦁ select Dolby Digital Plus ( we thought that meant you were selecting it- NOT TRUE)
⦁ Select Dolby Digital Output
⦁ select Dolby Digital OFF

When you go back to Digital & Sounds menu if you have done this correctly it will say in BIG WHITE LETTERS DOLBY DIGITAL Plus Off.

So if you are not getting that message in the 1st display & sound menu then you need to get that. So Audio is in yellow letters is on the left and on the right it says in White Dolby Digital Plus Off.

We only thought we had the Dolby Digital plus turned off but it was on. Dolby Digital is automatically preset to on, and so we had to persistently scroll through the audio settings to turn it finally off!
I also changed the setting from Dolby Digital Plus to Dolby Digital Automatic and it works fine now, with 5.1 surround sound where I had NO audio at all before.

2. Resetting the speaker options on my TELEVISION itself by going into the TV menu > speakers > option - internal or external. Changed it to INTERNAL.

3. Look for ADVANCE or something that may say AUDIO. Turn off DIGITAL audio auto detection. Click on DIGITAL audio output. Select the correct one for you....option will be PCM, SPDIF passthrough or HDMI passthrough. Try PCM first then the others.

4. Now reboot the Firestick or Fire TV and unplug the power for 5 seconds and plug it back in. Let it completley stabalize. That's it.
That's it!
 

rosario04

New member
Dec 31, 2016
5
0
0
I forgot. It has been recommended to connect my stick directly in hdmi port of the a/v receiver. Yes, I know that works. But, I would like it to make it work thru my tv's hdmi port. Thanks again.