G-box Q and kodi

jambo55

New member
Apr 7, 2014
22
0
0
Hi i have a new g-box q and i'm experiencing a strange problem. I downloaded the latest arm version of kodi (14.2) and installed. When i first started it i saw the first time message but after that the screen is completely black. If i press buttons i can hear system sounds in the background but nothing is showing on the screen. If i plug out the hdmi cable and plug it back in the video appears but if i exit the program it does the same thing and i have to restart the box.

Why this is so strange to me is because it had two versions of xbmc pre-installed and it does the same thing with one version which is 13.0 but not the other which is 13.2 but is a custom matricom version. Any help or ideas would be much appreciated.
 

TheLion

Member
Jun 2, 2013
904
0
16
Central Florida USA
From what I understand (and I used to use an mx2)the mx boxes were meant to use matricoms proprietary xbmc version on them.

Not to say it won't work with the new kodi but if it were me I'd just stick with the matricom xbmc and try to make it work, but that's me.

Did you try to put kodi on it? How about openelec? I hear openelec is awesome on those boxes. Maybe you should look into it if you can't get this sorted.
 

jambo55

New member
Apr 7, 2014
22
0
0
From what I understand (and I used to use an mx2)the mx boxes were meant to use matricoms proprietary xbmc version on them.

Not to say it won't work with the new kodi but if it were me I'd just stick with the matricom xbmc and try to make it work, but that's me.

Did you try to put kodi on it? How about openelec? I hear openelec is awesome on those boxes. Maybe you should look into it if you can't get this sorted.
It's kodi that's giving me the black screen. Whenever it loads up the screen is just blank but if I press buttons I can hear the system sounds.

If I plug out the HDMI and plug it back in the images appear but if I exit kodi the screen goes black again and I have to unplug/replug for the screen to come back.

The marticom xbmc that's preinstalled works fine but its based off Gotham 13.2 and some of the newer addons like the stalker add-on and Pushbullet only work on kodi.
 

TheLion

Member
Jun 2, 2013
904
0
16
Central Florida USA
Try playing around with setting hdmi then. Another thing you could try is Ask matricom how to handle the kodi problem. Finally if you dont get the results you want you can always sell it on ebay and get a box that works like it should. Get a fire tv or a windows box or an ouya, any of them will work for certain.

Life is too short to struggle with a circuitboard.
 

Phryzm

New member
Dec 8, 2014
106
0
0
Did you update the Q FW after you got it?
From what I heard you have to update the box right off the bat.
 

jambo55

New member
Apr 7, 2014
22
0
0
Did you update the Q FW after you got it?
From what I heard you have to update the box right off the bat.
No i didn't but I thought of that and tried to afterwards but it kept saying error when I tried to update it.
 

Phryzm

New member
Dec 8, 2014
106
0
0
No i didn't but I thought of that and tried to afterwards but it kept saying error when I tried to update it.
That's you problem right there, Matricom server been DOWN for almost a month now from what I've heard.
And there's no definite answer when it will be back online, so you're in a bind.
 

jambo55

New member
Apr 7, 2014
22
0
0
That's you problem right there, Matricom server been DOWN for almost a month now from what I've heard.
And there's no definite answer when it will be back online, so you're in a bind.
Damn and thanks for sharing that. I have no problems using the 13.2 custom edition it's just those new addons...
 

rkogen

New member
Jun 9, 2013
31
0
0
Matricom website states there is a problem with their Q box not taking any KODI upgrades. They are supposedly working on the problem and stated they would inform their users when the issue is fixed.Users will have to be content with the Kodi version that comes preinsyalled until this issue is fixed. Don't kill the messenger!LOL
 

hurst2001

New member
Dec 10, 2013
71
0
0
Matricom website states there is a problem with their Q box not taking any KODI upgrades. They are supposedly working on the problem and stated they would inform their users when the issue is fixed.Users will have to be content with the Kodi version that comes preinsyalled until this issue is fixed. Don't kill the messenger!LOL
I know this old post but I did install Kodi 15 on my q- box which I used the arm version which is android and still did not over right the 14.2 version R 3 that came with the box .. So my question is should use the Linux version that will over right the stock version on there know? Thanks for any input
 

Kutty

New member
Sep 30, 2015
7
0
0
I use TWO Q Boxes with Kodi 14.2 and do not have any complaints at all! Except the fact that I am not at all happy with the Remote Control that comes with it. Now I switched to a Wireless Mouse and it solved the problem too! I do get messages to upgrade to the latest 15.x version. Tried but many of the commonly used Add-Ons did not work! When I run these add-ons, the systems shows "Working..." and never ends! (Example of non-worling Add-Ons on Kodi 15.x on the Q-Box : TV On DesiZone)
 

filly

New member
Jan 31, 2013
85
0
0
Canada
I updated to 15.2 through the google play store. Have not had any problems. Did not loose any addons either.
 

FORD

Member
Oct 24, 2013
51
0
6
If you only need Kodi on the G-box Q, your best option is to get rid of Android altogether and run OpenElec on it. There's no "official" build for this hardware at the OpenElec site, but there are some good ones out there.

Here's a link to the most recent build.

Extract to the SD card and install via the usual "toothpick" recovery method. I've been running this since it was released in late November, and have no complaints. (other than the corporate bastards at Comca$t messing with the streams, but that's nothing to do with the operating system, of course)