[GUIDELINES] Submitting Bug Reports

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
In order to make troubleshooting issues with USTVnow Plus more manageable I have decided to post some guidelines for what is expected in a "bug/issue" report.

Note:
If you are experiencing issues with your login credentials on an account that previously worked this could be caused by a known issue USTVnow system.

Please read this thread for more info:

USTVnow Common Issues and Misconceptions
Please try/provide the following:

  • Before submitting an issue please read the note above. :D
  • Before submitting an issue please ensure that you are using the latest version of USTVnow Plus and/or USTVnow Guide
  • Before submitting an issue please restart Kodi to see if that clears things up
  • Before submitting an issue please visit the USTVnow website and see if you are having issues there. If so then the issue is with the USTVnow service and not the USTVnow Plus addon
  • Please post all bug reports in the correct thread. (USTVnow Plus or USTVnow Guide)
  • Version number of USTVnow Plus that you are using
  • Version number of USTVnow Guide that you are using
  • Debug log (see my signature for help with getting the log)

Remember you are not paying for USTVnow Plus and I am not getting paid to develop it.

I hope this will help streamline the process so that I can be more effective in helping with issues. I don't want this to sound rude. I just want to be able to help as best as I can.

Thanks!
 
Last edited:

QueenB

New member
Apr 9, 2016
1
0
0
Ustv on kodi help

I'm not sure if this has been asked but I pay for USTV all channels but on kodi it is only showing the channels on the free plan. On all other devices it shows all the channels. They referred me here for help.
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
I'm not sure if this has been asked but I pay for USTV all channels but on kodi it is only showing the channels on the free plan. On all other devices it shows all the channels. They referred me here for help.
It sounds like your account has something special about it. I have found a few others like this. If you can PM me I can most likely add some logic in the addon to deal with this. To make this go the fastest I will need your login creds. ( you can change them when I am done fixing it ).

Thanks
 

pappy177

New member
Aug 23, 2016
2
0
0
This is what mine does (amazon fire box with kodi ) But the list without icons has everything.
 

pappy177

New member
Aug 23, 2016
2
0
0
There is tv guide (epg) that is icons on mine. and list witch has none.
But it works today , ie abc has the black ball.
Thanks for answering anyway !
 

Shintai4

New member
Apr 8, 2017
1
0
0
Im hoping you can help, as i have gone to USTVNow folks and they say they cant as Kodi/TVaddons is 3rd party.

Since updating my system on my fire stick, i am not able to enjoy what previois to the update i did just fine. I.e. Ustvnow. I think i have the latest version, and my account is active with them, yet when i pull up the app to watch something, i get nothing.


I see the guide list just fine, and it has all that a free account should, i just cant actually watch anything.

Plz help
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
Im hoping you can help, as i have gone to USTVNow folks and they say they cant as Kodi/TVaddons is 3rd party.

Since updating my system on my fire stick, i am not able to enjoy what previois to the update i did just fine. I.e. Ustvnow. I think i have the latest version, and my account is active with them, yet when i pull up the app to watch something, i get nothing.


I see the guide list just fine, and it has all that a free account should, i just cant actually watch anything.

Plz help
USTVnow does not support the Kodi addon. So it is best to never mention it to them. It just distracts them.

Have you tried creating a new free account? There have been many posts lately explaining why this may be needed.
 

Cowboy1968

New member
Dec 11, 2015
4
0
0
Hi,
I too am having issues watching my USTVNow account using the Kodi Addoon.

I can log in just fine and it shows via the addon that my account is active etc but nothing will play. I have verified that my account is working fine by logging into USTVNow's website and watching TV there. I also tried a friends account and again where it would log him in in the Kodi addon and show as active, nothing would play. I tired deleting the addon, and the ustvnow guide addon, clearing cache etc, rebooting and yet when I reinstall the addon it remembers my login info and settings like it was never deleted. I assume there is a file or folder somewhere that does not get deleted that contains this info. Perhaps if someone can advise me if this is so and where it is I can delete it and then try reinstalling the addon fresh.

As to signing up for a new free account, in my experience it will not work. I tired the signup with email address option, but I get an error saying that is not available right now and to only use Google+ or Facebook, neither of which requires a password, which means it wont work with the addon that requires a username/password combo. I asked USTVNow directly why the email signup is not available for free users and they could not give an answer, but told me that it would not be an option for the for the foreseeable future. If you go with the free for 45 days route, you can use the email signup, but your account will stop working after the 45 days unless you pay.

I am getting the distinct impression they are doing this to stop people from using kodi etc to watch the free streams, but that is just my impression.

Any help or guidance would be appreciated.

Thank You
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
Hi,
I too am having issues watching my USTVNow account using the Kodi Addoon.

I can log in just fine and it shows via the addon that my account is active etc but nothing will play. I have verified that my account is working fine by logging into USTVNow's website and watching TV there. I also tried a friends account and again where it would log him in in the Kodi addon and show as active, nothing would play. I tired deleting the addon, and the ustvnow guide addon, clearing cache etc, rebooting and yet when I reinstall the addon it remembers my login info and settings like it was never deleted. I assume there is a file or folder somewhere that does not get deleted that contains this info. Perhaps if someone can advise me if this is so and where it is I can delete it and then try reinstalling the addon fresh.

As to signing up for a new free account, in my experience it will not work. I tired the signup with email address option, but I get an error saying that is not available right now and to only use Google+ or Facebook, neither of which requires a password, which means it wont work with the addon that requires a username/password combo. I asked USTVNow directly why the email signup is not available for free users and they could not give an answer, but told me that it would not be an option for the for the foreseeable future. If you go with the free for 45 days route, you can use the email signup, but your account will stop working after the 45 days unless you pay.

I am getting the distinct impression they are doing this to stop people from using kodi etc to watch the free streams, but that is just my impression.

Any help or guidance would be appreciated.

Thank You
I am not sure why some users experience issues creating a new free account using an email. I have never seen that option not be available.

Can you send me the URL that you used to try and create a new account where the email option was not available?
 

Cowboy1968

New member
Dec 11, 2015
4
0
0
I am not sure why some users experience issues creating a new free account using an email. I have never seen that option not be available.

Can you send me the URL that you used to try and create a new account where the email option was not available?
You reply got me thinking, so I tried something out. I used my work computer to try and set up an account and it worked fine, but then I tried to do one on my home computer, and I also tried using a vpn on my home computer so it was two different IP's and both gave me the unavailable at this time error. What is even stranger, is when I asked USTV NOW directly I got a response back that email signups were not available and will not be for the foreseeable future.

I can't explain any of it, but now at least I have a working account but I have run into another issue though.

I entered my new info into the addon and after a reboot everything is working fine with the USTVNow kodi addon except for the EPG guide, the list one is working fine. It stops at estimating time of download (or something like that) after populating the names of the channels/logos and the spinning wheel of waiting just keeps going. I have googled this and done the following several times to no effect.

1) reset everything to default in the EPG guide settings
2) reset the database
3) rebooted
4) cleared cache

I tired to uninstall and reinstall the whole shebang (guide and USTV NOW addon) cleared cache and rebooted, but when I reinstall it it remembers my login and all my settings so it does not fix the issue.

Any help would be greatly appreciate thanks
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
You reply got me thinking, so I tried something out. I used my work computer to try and set up an account and it worked fine, but then I tried to do one on my home computer, and I also tried using a vpn on my home computer so it was two different IP's and both gave me the unavailable at this time error. What is even stranger, is when I asked USTV NOW directly I got a response back that email signups were not available and will not be for the foreseeable future.

I can't explain any of it, but now at least I have a working account but I have run into another issue though.

I entered my new info into the addon and after a reboot everything is working fine with the USTVNow kodi addon except for the EPG guide, the list one is working fine. It stops at estimating time of download (or something like that) after populating the names of the channels/logos and the spinning wheel of waiting just keeps going. I have googled this and done the following several times to no effect.

1) reset everything to default in the EPG guide settings
2) reset the database
3) rebooted
4) cleared cache

I tired to uninstall and reinstall the whole shebang (guide and USTV NOW addon) cleared cache and rebooted, but when I reinstall it it remembers my login and all my settings so it does not fix the issue.

Any help would be greatly appreciate thanks
That is interesting. I can say this... The USTVnow support folks don't seem to really understand how their system works fully. :)

As for the Guide issues...

I just found the issue and corrected it. Should be working now. Might need another DB reset, but I don't think so. I basically had a typo in the service that generates the xmltv file for Free accounts. I didn't see the issue at first because I use a Paid account for most things.
 

Cowboy1968

New member
Dec 11, 2015
4
0
0
That is interesting. I can say this... The USTVnow support folks don't seem to really understand how their system works fully. :)

As for the Guide issues...

I just found the issue and corrected it. Should be working now. Might need another DB reset, but I don't think so. I basically had a typo in the service that generates the xmltv file for Free accounts. I didn't see the issue at first because I use a Paid account for most things.
Thank you so much for your help, yes everything is working normally again.

Thank you for your patience!
 

Momofterrors

New member
May 24, 2017
3
0
0
oh, I am having similar problems with USTVNow. everything is set up ok correct password and email but when I click on anything in the menu nothing happens. we loved watching it, so it is a big loss..
I am now using 17.3 and it is still doing the same. am using a WISEWO T95Z PLUS Android TV Box
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
oh, I am having similar problems with USTVNow. everything is set up ok correct password and email but when I click on anything in the menu nothing happens. we loved watching it, so it is a big loss..
I am now using 17.3 and it is still doing the same. am using a WISEWO T95Z PLUS Android TV Box
Free account? How old is the account? If it is over 45 days old you may have to open a new free account.
 

meg4c

New member
May 28, 2017
2
0
0
I'm new to USTV, set up a free account, got an email welcoming me, entered my log in credentials and it says log in failed, check credentials, when I look in settings, all the info is correct, I'm so confused

I closed out and rebooted KODI, that didnt fix it
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
I'm new to USTV, set up a free account, got an email welcoming me, entered my log in credentials and it says log in failed, check credentials, when I look in settings, all the info is correct, I'm so confused

I closed out and rebooted KODI, that didnt fix it
Did you signup using Google or Facebook? If so that will not work. You mush signup using and email address. If you did use an email to signup double check your creds. That is almost always the issue if everything else is correct.
 

Tuuvian

New member
Jul 14, 2014
8
0
0
I am a paid subscriber since 2013 and my subscription is current renewing on June 25th.

I am able to watch online on their website but have been unable to do so with the kodi addon for a few weeks, although it used to work to that point. Running Kodi 17 Librelec latest on a pi3.

I can provide the full log but here is a snipet from the one try to watch ABC:

18:02:45.835 T:1962266432 NOTICE: VideoPlayer: Opening:
18:02:45.836 T:1962266432 WARNING: CDVDMessageQueue(player)::put MSGQ_NOT_INITIALIZED
18:02:45.846 T:1072690080 NOTICE: Creating InputStream
18:02:45.871 T:1072690080 ERROR: Error on dvdnav_open
18:02:45.872 T:1072690080 ERROR: CVideoPlayer::OpenInputStream - error opening []
18:02:45.872 T:1072690080 NOTICE: CVideoPlayer::OnExit()
18:02:45.872 T:1962266432 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.ustvnow.tva/?name=ABC&mode=play&rand=LSPHPL]
18:02:45.883 T:1962266432 NOTICE: CVideoPlayer::CloseFile()
18:02:45.883 T:1962266432 NOTICE: VideoPlayer: waiting for threads to exit
18:02:45.884 T:1962266432 NOTICE: VideoPlayer: finished waiting
18:02:45.884 T:1962266432 NOTICE: CVideoPlayer::CloseFile()
18:02:45.884 T:1962266432 NOTICE: VideoPlayer: waiting for threads to exit
18:02:45.884 T:1962266432 NOTICE: VideoPlayer: finished waiting

Any guidance or assistance will be greatly appreciated.