Request Help with Error - Failed to install Add-on from zip

HopeSlayer

New member
Jan 4, 2017
6
0
0
Hello, any help is greatly appreciated! I'm getting an Error when trying to install certain Add-ons from Fusion. The add-on installer, Ex**us, and Metalkettle all send an error message but, Dudehere works. They seem to be timing out for some reason. If I goto http://fusion.tvaddons.co/kodi-repos/english/repository.Ex**us-1.0.1.zip in my browser and download/install the zip then it works. I'm using a VNC so I don't think that my ISP is blocking anything... I have tried everything I can think of to fix this.

Log File http://paste.ubuntu.com/23737726/

Things I have tried:
  • Fresh installs of V17 and V16.1 (Used "Total Uninstall" to clear registry)
  • fusion -> xbmc-scripts -> scripts.module.urlresolver (error - failed to install)
  • Manual delete C:\Users\elo\AppData\Roaming\Kodi\
  • Turn off Firewall and Virus protection
  • Fresh install on D: drive instead of C:

I'm hoping someone can "save the day" for me, before I pull the trigger on a fresh Windows install... Thanks in advance for any advice.
 
Last edited:

HUF

New member
Dec 27, 2016
30
0
0
England
Hello, any help is greatly appreciated! I'm getting an Error when trying to install certain Add-ons from Fusion. The add-on installer, Ex**us, and Metalkettle all send an error message but, Dudehere works. They seem to be timing out for some reason. If I goto http://fusion.tvaddons.co/kodi-repos/english/repository.Ex**us-1.0.1.zip in my browser and download/install the zip then it works. I'm using a VNC so I don't think that my ISP is blocking anything... I have tried everything I can think of to fix this.

Log File http://paste.ubuntu.com/23737726/

Things I have tried:
  • Fresh installs of V17 and V16.1 (Used "Total Uninstall" to clear registry)
  • fusion -> xbmc-scripts -> scripts.module.urlresolver (error - failed to install)
  • Manual delete C:\Users\elo\AppData\Roaming\Kodi\
  • Turn off Firewall and Virus protection
  • Fresh install on D: drive instead of C:

I'm hoping someone can "save the day" for me, before I pull the trigger on a fresh Windows install... Thanks in advance for any advice.
Hey can you use this method to install Ex**us
Select SYSTEM
Select Add-Ons
Select Install from zip file
Select fusion
Select kodi-repos
Select english
Select repo.Ex**us.x.x.x.zip
Wait for Add-on enabled notification
Select Install from repository
Select Ex**us repository
Select Video add-ons
Select Ex**us
Select Install
Wait for Addon enabled notification

You should also see the Metalkettle repository there it's all set in alphabetical order :)
 

HopeSlayer

New member
Jan 4, 2017
6
0
0
That is the method I was trying. Instead of "Add-on enabled notification" I'm getting "Error Failed to install Add-on from zip"
 

HUF

New member
Dec 27, 2016
30
0
0
England
That is the method I was trying. Instead of "Add-on enabled notification" I'm getting "Error Failed to install Add-on from zip"
What is your kodi version is it jarvis or isengard or even krypton? also are you using a build as this can really be an the reason your getting errors
 

FXB78

Member
Aug 18, 2013
981
0
16
The log indicates, as you say it times out:

Code:
XFILE::CDirectory::GetDirectory - Error getting zip://http%3A%2F%2Ffusion.tvaddons.co%2Fkodi-repos%2Fenglish%2Frepository.Ex**us-1.0.1.zip/
I just tried to replicate it using Krypton on Windows the same as you, and it works fine.

Check your firewall/AV/VNC isn't causing any problems, I can't think what else it could be.
 
Last edited:

HopeSlayer

New member
Jan 4, 2017
6
0
0
The log indicates, as you say it times out:

Code:
XFILE::CDirectory::GetDirectory - Error getting zip://http%3A%2F%2Ffusion.tvaddons.co%2Fkodi-repos%2Fenglish%2Frepository.Ex**us-1.0.1.zip/
I just tried to replicate it using Krypton on Windows the same as you, and it works fine.

Check your firewall/AV/VNC isn't causing any problems, I can't think what else it could be.
Thanks for trying to duplicate the error. I already tried to disable firewall and virus. Some repository work on fusion like dudehere so I don't think it's VPN. All repository from non fusion sources install without error.
 

HopeSlayer

New member
Jan 4, 2017
6
0
0
What is your kodi version is it jarvis or isengard or even krypton? also are you using a build as this can really be an the reason your getting errors
V17 and 16.1 as stated in OP. No builds. Fresh downloads from kodi.tv
 

Mando131

New member
Jan 7, 2017
2
0
0
I have the exact same problem for windows 10, keeps on saying Ex**us failed to install.
 

HopeSlayer

New member
Jan 4, 2017
6
0
0
Well... after trying everything I could, I finally reinstalled Windows 7. Ex**us installs without any issues now. I wish I knew what the problem was, but it seems a fresh install of Windows has fixed it. Thanks everyone for your attempts at helping me.
 

BeerBelly

New member
Jan 22, 2017
1
0
0
Hi Guys,

I have just formatted and reinstalled windows on my media PC and am getting the same error as HopeSlayer when trying to install the Ex**us addon and I cannot work out wtf is going on. I don't think it is anything to do with my VPN/net access as I have Ex**us running fine on a Win10 machine in my house. I am running Jarvis and Kodi is allowed through my firewall. Any ideas of what else I could try?

Thanks very much in advance
 

HopeSlayer

New member
Jan 4, 2017
6
0
0
After updating Kodi, the failed to install addon error returned. I Uninstalled my VPN (AirVPN) and Ex**us installed without an issue. So, I reinstalled the VPN and tried to reinstall Ex**us, to verify the error is related to the VPN, and I received the error again. It could be the VPN software changes my firewall settings and will not allow certain repositories to connect? Hope this helps someone.