Jail Breaking older iPod

shark1959

New member
Mar 26, 2013
19
0
0
Canada
Hi All:

I have an older 3G iPod Touch and before I run into any potential issues, will this evasi0n jailbreak work on anything lower than what's noted in the requirements? The software is currently at 5.1.1 and according to the device is up to date. Should I be good to go, I'm guessing anything below 7.0.4 is ok but, just wanted to make sure first?
Thanks in advance.

Cheers :)

Shark1959