Keeps crashing.

jambo55

New member
Apr 7, 2014
22
0
0
I see there are numerous threads of persons xbmc crashing but the reason i created this thread is because i have some questions as well. I recently did the zero cache because i'm on a slower connection and watching stuff was nearly impossible for me because it would just buffer and it would not load any further. Having done the cache thing my videos now load up whilst paused allowing me to watch stuff. Now though i''m not sure if it's because of the zero cache but videos just keep crashing after less than a minute. Any ideas anyone?
 

donmacf15

New member
Sep 19, 2014
16
0
0
I had a problem with constant crashing too mate and the guys on here were amazing. If I had hair I would've pulled it out I kid you not.

Anyway although not given any specific advice the jist was that after I had sideloaded TVMC I added other stuff that isnt supported on here. Which made me go back and uninstall said "stuff". In effect I did a process of elimination and so far it has worked like a charm.

In Video - Settings under Acceleration I unchecked "Allow hardware acceleration (MediaCodec)" as recommended by other forumites. I then, again under Video-Settings-Live TV-General, unchecked the Enabled tab to stop from getting the live tv (IPTV) with too many channels much of which doesnt work and which I suspect was destabilising my aftv although I have no proof that this was indeed the problem.

My advice would be to sideload TVMC for android and enjoy the content provided by that configuration which I have found to be more than enough for my needs.

I also sideloaded SPMC and used the config wizard (using Fusion as the source) to add the content via the aftv section. I then uninstalled what I didnt want, leaving me with very little. I will add more in time to see how it performs.

Hope this helps
 

jambo55

New member
Apr 7, 2014
22
0
0
I had a problem with constant crashing too mate and the guys on here were amazing. If I had hair I would've pulled it out I kid you not.

Anyway although not given any specific advice the jist was that after I had sideloaded TVMC I added other stuff that isnt supported on here. Which made me go back and uninstall said "stuff". In effect I did a process of elimination and so far it has worked like a charm.

In Video - Settings under Acceleration I unchecked "Allow hardware acceleration (MediaCodec)" as recommended by other forumites. I then, again under Video-Settings-Live TV-General, unchecked the Enabled tab to stop from getting the live tv (IPTV) with too many channels much of which doesnt work and which I suspect was destabilising my aftv although I have no proof that this was indeed the problem.

My advice would be to sideload TVMC for android and enjoy the content provided by that configuration which I have found to be more than enough for my needs.

I also sideloaded SPMC and used the config wizard (using Fusion as the source) to add the content via the aftv section. I then uninstalled what I didnt want, leaving me with very little. I will add more in time to see how it performs.

Hope this helps
Hi thanks for the reply, i unticked the mediacodec and it seems to have solved my problem. If it persists i'll try those other options you mentioned.
 

jambo55

New member
Apr 7, 2014
22
0
0
I bump this thread because it's happening again. Every time I'm watching a movie about 30 seconds in it just closes, not xbmc but the movie just crashes taking me back to the xbmc home screen.
 

ZackRampage

New member
Jul 24, 2013
62
0
0
New York City
Is it recommended yet to update to the latest beta of kodi? Not that I am experiencing problems with gotham 13.2 just curious. If some what is the best way to update without losing everything if possible?
 

KLit75

New member
Jun 10, 2014
618
0
0
Do you really mean "every" time? Because I've experienced what you're describing but for me it's certain tv shows (very few) and I'd say it was the server but my rpi will play the same ones.
If that's the case I'd do a fresh start with a different version of xbmc. If you're not into that get a debug log and see if someone can help. If you believe the problem is with your aftv (and I have absolutely no reason to think that) we do have an option for custom recovery now. With clockworkmod you can do a factory reset and/or install prerooted firmware. Aftvnews simplifies it in their guides.
I'm not certain this will help but I'd be surprised if one of them doesn't correct your issues. Pin pointing it is hard without a log and even then you need someone to read and diagnose.
 

jambo55

New member
Apr 7, 2014
22
0
0
Do you really mean "every" time? Because I've experienced what you're describing but for me it's certain tv shows (very few) and I'd say it was the server but my rpi will play the same ones.
If that's the case I'd do a fresh start with a different version of xbmc. If you're not into that get a debug log and see if someone can help. If you believe the problem is with your aftv (and I have absolutely no reason to think that) we do have an option for custom recovery now. With clockworkmod you can do a factory reset and/or install prerooted firmware. Aftvnews simplifies it in their guides.
I'm not certain this will help but I'd be surprised if one of them doesn't correct your issues. Pin pointing it is hard without a log and even then you need someone to read and diagnose.
Disabling the live TV seemed to have fixed it. I'll do some more testing and see. Many thanks for your reply, I've been following the pre rooted firmware thread but I'm not ready to make such a leap. I'm rooted on an early firmware with play store and such.
 

Banister

Member
Nov 3, 2013
121
1
18
Disabling the live TV seemed to have fixed it. I'll do some more testing and see. Many thanks for your reply, I've been following the pre rooted firmware thread but I'm not ready to make such a leap. I'm rooted on an early firmware with play store and such.
Can someone point me to a thread about pre rooted firmware? I've searched every thread in the Fire TV forum and haven't seen mention about this. Does this mean we can sideload to downgrade the software and then root???
 

KLit75

New member
Jun 10, 2014
618
0
0
Can someone point me to a thread about pre rooted firmware? I've searched every thread in the Fire TV forum and haven't seen mention about this. Does this mean we can sideload to downgrade the software and then root???
You won't find what you need here. Preroot fw is from a developer on xda. But I'd recommend you use the guides on aftvnews. Xda has them and that is where you may be redirected to for downloads but aftvnews does a great job of breaking it down.
Oh. I just read your last sentence. No. It doesn't mean that. You need to be rooted first. Sorry if that was unclear. This basically allows you to update, something rooted devices can't do without losing root.
 
Last edited:

Banister

Member
Nov 3, 2013
121
1
18
Thanks for clarifying that for me. I lost my root due to my own fault and was hoping I'd be able to do this.

I know I derailed the thread, but I too am experiencing sporadic crashes mainly when attempting to watch movies and it's happening with several addons such as Ic*f*lms, 1Ch**nel, Na*i-X etc.
 

KLit75

New member
Jun 10, 2014
618
0
0
Other than what I suggested earlier in the thread, not sure your best course of action. I'm running 13.2. It's been stable. No live tv but the new Pho*nix add-on is a nice substitute combined with Supersu favorites plus my isp has an app with live tv option.
I use genesis which pulls from those add-ons you mentioned and have very few issues at this time. Good luck.