Kodi 17.1 video stalling issues via SMB

dominicoo

New member
Apr 10, 2017
3
0
0
Hi all. I'm a relative novice with Kodi's advanced functions. I have having issues playing back video files on Kodi (on a new Amazon Fire Stick with Alexa remote) from my networked laptop via SMB. Specifically, I am trying to play a large video file in x264 format (720p). Running Kodi 17.1 on the AFTV. The video plays fine for about 20 minutes or so and then stalls for a few seconds, with Kodi kicking out of the movie and back to the file list in SMB. When I go to resume the video, it resumes fine but will stall out again in about 20 minutes or so. This problem started happening a few weeks ago (also on the older Jarvis version). Prior to a few weeks ago, I have played numerous files from my laptop to completion just fine. This only appears to happen only when playing files from SMB.

FYI, I changed my advancedsettings to: cachmembebuffersize 157286400 (also tried smaller cache sizes down to 30MB or so given the Fire Stick), buffer mode 1, and readbufferfactor 5 (also tried 10). It happens with either settings.

Here is a copy of the Kodi log:

https://pastebin.com/7ENGqcYX


any help would be greatly appreciated!!
 

Meep

New member
Aug 23, 2016
692
0
0
Well for one, unless you know what you are doing and have a limited reason to change the advanced settings, it's best to avoid the temptation...

And this is one reason for my above comment, cachmembebuffersize, readbufferfactor and is outdated syntax, it does nothing for Kodi 17.1 and will be ignored... In all likelihood any changes you made to advancedsettings.xml are being ignored as you are using the wrong syntax for 17.1... So best to just delete it, and/or remove any additions you made at this point, it's not going to help your problems...

The log looks like the video connection was simply closed, check the power saving options on the sever, chances are the computer is shutting off the hard drive, LAN simply going to sleep after 20 minutes and thus the connection is broken...
 
Last edited:

dominicoo

New member
Apr 10, 2017
3
0
0
Thanks Meep. Now that I think of it, I did recently upgrade my OS (Win10) and router so maybe one of the two have something to do with it. Laptop is connected via 5GHz and AFTV connected via 2.4GHz.

As far as changing advanced settings, I did so because I needed to enable LAN buffering via buffermode 1. Back on Jarvis, it would buffer a lot because of the default no LAN buffering. What does Krypton do by default? Is there an addon that makes the correct changes on Krypton? I currently use EZAdvancedSettings.
 

Meep

New member
Aug 23, 2016
692
0
0
As far as changing advanced settings, I did so because I needed to enable LAN buffering via buffermode 1. Back on Jarvis, it would buffer a lot because of the default no LAN buffering. What does Krypton do by default? Is there an addon that makes the correct changes on Krypton? I currently use EZAdvancedSettings.
I would never use an addon for such a trivial task, and I honestly cringe at them, as well as all the stupid blogs and videos telling people to change the settings, when for most of the people it will accomplish nothing and potentially make things worse...

Change your Kodi 17.1 advancedsettings.xml to, it's just a text file open it with Windows Notepad or an OS equivalent text editor, edit and save,no fancy addon or anything needed...

This is the correct syntax for Kodi 17.1 to change the buffermode to 1...

Code:
<advancedsettings>
<cache>
<buffermode>1</buffermode>
</cache>
</advancedsettings>
http://kodi.wiki/view/HOW-TO:Modify_the_video_cache
 

dominicoo

New member
Apr 10, 2017
3
0
0
Thanks for the info. I definitely don't use addons for changing a simple xml file on my PC's Kodi. But on my Fire Stick it's just for the convenience. Thanks again.
 

AsphyxNYC

New member
Apr 7, 2017
22
0
0
I would bet money that the problem is the Laptop putting the WiFi adapter to sleep after 20 minutes.
So in Win10 check your advanced power settings...

Open Settings - System - Power & Sleep - Additional - Change Plan - Advanced - Wireless Adapter - Power Saving
Set to Maximum performance

There is also a setting for Hard Disk in that Advanced window...Set Turn off Hard disk to 0 (disabled)

Laptops are very poor at sharing file content since they are usually setup and designed for minimal power usage.
I suggest looking into investing in a NAS where you can keep your library. I have 24TBs of content on NAS storage and it's available to multiple Kodi Boxes in my house.

I suggest for regular use of the laptop to create a new Power Profile to make these setting changes or use the When Plugged in profile.
You want the laptop to shut those devices down when there is no power to save your battery.
Then when you want to use it as a file server all you need to do is plug it in.
 
Last edited: