Kodi 17.1 won't open after installing upgrade

gordyic

New member
Apr 4, 2017
2
0
0
I was running Kodi Jarvis on my HP PC laptop with Windows 10 with no problems.
I got the message to upgrade to 17.1
I followed the updating instructions and got as far as Stage 3.
I downloaded the installer and ran it. Clicked 'Run Kodi' and then finish. Nothing, it won't open at all. I 'allowed' it on my Norton firewall permissions and still nothing.
I've uninstalled many times and even done a complete clean install deleting all profiles etc. Still won't open
The indigo tool was installed and I followed the instructions regarding that.
I reinstalled Kodi Jarvis just to see if that worked and it opens up and workes perfectly.
What am I doing wrong? Is there something I should be doing in preparing for the upgrade?
Is there a permissions setting I have to hit to allow it to open?

regards
Gordon
 

GemK23

New member
Apr 3, 2017
2
0
0
I am having the exact same issue. I tried to fix it all last night and was up til 5am this morning and still nothing. I really wish I hadn't touched a thing. I also made sure all my drivers were up to date, run virus scans, cleared everything etc etc and still it will not open. I also downloaded both versions as in the main one and the windows store version, still nothing.

From what I saw last night, we're not the only ones here to be having the issue either.

Oh and my laptop is new, so I know there is not an issue with my laptop, so I'm at a loss on what the issue is.
 

Stoofer

Moderator
Staff member
Apr 18, 2015
674
0
0
Wales
Probably best to head on over to Kodi.tv and check out what the people who wrote it have to say. A cursory read of the Forums shows some possible suggestions, I would try the Addons27.db deletion first and see if that works for you.
 

GemK23

New member
Apr 3, 2017
2
0
0
Probably best to head on over to Kodi.tv and check out what the people who wrote it have to say. A cursory read of the Forums shows some possible suggestions, I would try the Addons27.db deletion first and see if that works for you.
That worked. I thought I'd already done this by deleting all Kodi files but clearly not. Thank you so much.
 

gwilly7

New member
May 26, 2014
169
0
0
Broncos Country
I have done a few upgrades for friends lately and had the same issue. For me the issue seemed to be caused by having the old Lamda or Kinkin repo installed on the system being upgraded. I have now started removing those two repos before upgrading and have not had the issue any longer.
 

egwphd

New member
Jan 23, 2013
28
1
3
If Kodi doesn't open, how can I delete something in it?
It might be a lot to ask, but how about a step-by-step?
 

Katlaya

New member
Mar 18, 2017
6
0
0
I am also having a MAJOR problem with Kodi now. I can get it to open, but nothing works, so getting it open holds little value. I just spent the money for a year's worth of RealDebrid, which is useless now and paid for a VPN service. The thing that really make me angry is they were supposed to TEST THIS FOR BUGS BEFORE PUTTING OUT THE FINAL PROGRAM!!! If you have the final program and it's not working in Windows 10, that's a major problem! My beta Krypton Kodi worked better. I want to know how in the name of all that's good, would Kodi developers put out the final version without checking out MICROSOFT?????
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,621
69
48
The Halls of Valhalla
I am also having a MAJOR problem with Kodi now. I can get it to open, but nothing works, so getting it open holds little value. I just spent the money for a year's worth of RealDebrid, which is useless now and paid for a VPN service. The thing that really make me angry is they were supposed to TEST THIS FOR BUGS BEFORE PUTTING OUT THE FINAL PROGRAM!!! If you have the final program and it's not working in Windows 10, that's a major problem! My beta Krypton Kodi worked better. I want to know how in the name of all that's good, would Kodi developers put out the final version without checking out MICROSOFT?????
Well, I'm glad you see it this way. Kodi is open source. So all you have to do is recode it to work properly and send the new code to the XBMC foundation. To be included In their next release. Or, if you're like me and do not code, you can simply sit back, enjoy what others do for free and wait for a fix to come out.

But looking at the millions who have a working system on all platforms, I can only think that the problem is with your system. Check your router, firewall, VPN setup, AV..... So many things can go wrong, none of which is Kodi's fault.
 
Last edited:

Meep

New member
Aug 23, 2016
692
0
0
If you have the final program and it's not working in Windows 10, that's a major problem!
IF that was the case, sure that would be a big problem, but it's NOT the case... Kodi works perfectly fine on Windows 10, in contrast there appears to be an issue with your (and some others) particular computers, an issue unique to your systems that is causing the problem, not a global problem with Windows 10 and Kodi...

As a point of proof, I have Kodi 16.1, Kodi 17.1 and Kodi 18 Beta all on this very same Windows 10 laptop I'm typing on and all versions installed and work exactly as expected, so Kodi does in fact work quite well on Windows 10 as others will also confirm is the case for them...

Instead of jumping to the conclusion that it's all Kodi's fault, may I suggest you take a step back and consider the possibility that something is 'wrong' on your end... There are many, many variables to consider as there are 1000s upon 1000s of way to configure a computer and network as well as billions of possibilities of potential conflicting software on this or that system...

Yes there is a fault in the Kodi 17.1 upgrade that is causing some issues across many platforms, and that is something the Kodi developers really need to figure out, but it's not a global problem and appears to be isolated and random so it's a tough bug to track and figure out the cause...

That said, maybe it's time you elaborate on your issues if you would like some help...

You said "I can get it to open, but nothing works" what exactly does that mean? If you can get it to open then Kodi is working, is it not? Are you having an issue getting a particular addon to work? Are you confused by the skin changes? Are there errors popping up on the screen? Do you have a log? If you would like someone to attempt to help you, then you really need to be a team player and contribute, because you are the only one here that is sitting in front of your computer and having the problems...
 

Katlaya

New member
Mar 18, 2017
6
0
0
It is not my system. Totally cleaned out the "new" version and went back to the old version and it works seemlessly. Glad to have it back. I would pay for Kodi app if it meant better service and taking it for a spin before putting it out as a final version that people with Windows 10 can't use. I am FAR from being the only one. Just look at the blogs!
 

old dude

New member
Apr 10, 2017
9
0
1
Be careful going to kodi.tv. they do not like tvaddon.ag or want to assist us. Stay stealth. Some are very not social. I used the Uninstaller, rebooted, installed, kodi would stop working, downloaded 17.1 again, every thing works. I have no talent for this and I appreciate everyone efforts in making this work. All my add ons reloaded. How did that happen after uninstall? I even Uninstaller some old xbmc files.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,621
69
48
The Halls of Valhalla
Be careful going to kodi.tv. they do not like tvaddon.ag or want to assist us. Stay stealth. Some are very not social.
Yes, if you go there, be sure it is something that does not require posting a log and do not mentioned TVAddons.

I used the Uninstaller, rebooted, installed, kodi would stop working, downloaded 17.1 again, every thing works. I have no talent for this and I appreciate everyone efforts in making this work. All my add ons reloaded. How did that happen after uninstall? I even Uninstaller some old xbmc files.
That is because your userdata folder stayed behind. For a full virgin Kodi, you need to remove your Userdata folder completely.
 

old dude

New member
Apr 10, 2017
9
0
1
Sorry, again no talent. Between Kodi stopped working and re-download 17.1, I forgot to say, I went in and deleted addons27.db. I've learned a lot from these forums, thanks. Off to find out why ustvnow channels won't start.
 

Meep

New member
Aug 23, 2016
692
0
0
Off to find out why ustvnow channels won't start.
If you have a free account many problems can be 'fixed' by simply signing up for a new USTVnow account and using that instead, if you have a paid account, call them and have them bump you to a different server...
 

old dude

New member
Apr 10, 2017
9
0
1
Please don't take this personally and waste your time it. Some people think they are owed. This is free and fun. I love it and hate when it doesn't work, but know a solution will be developed. I fumble through this all the time. Not of this generation. Appreciate those who get it.
 

old dude

New member
Apr 10, 2017
9
0
1
My last was to Meep. Does it matter that everything works fine when I use ustvnow site and account? Inside addon ustvnow plus, get all the way to selecting the channel and then get the swirly without opening the channel or the credentials window.
 

Meep

New member
Aug 23, 2016
692
0
0
My last was to Meep. Does it matter that everything works fine when I use ustvnow site and account? Inside addon ustvnow plus, get all the way to selecting the channel and then get the swirly without opening the channel or the credentials window.
Th USTVnow addon is not 'official' if you go to the developers section you can see the author 'reverse engineered' their website API... That said, yeah sometimes the site will work and the addon will not for some quirky unknown reason, thus the 'fixes' I posted above for whatever reason seem to resolve addon playback issues for many...
 

old dude

New member
Apr 10, 2017
9
0
1
Th USTVnow addon is not 'official' if you go to the developers section you can see the author 'reverse engineered' their website API... That said, yeah sometimes the site will work and the addon will not for some quirky unknown reason, thus the 'fixes' I posted above for whatever reason seem to resolve addon playback issues for many...
You were right on the mark. I deleted my ustvnow account and created another. Works perfectly. I struggled with this for days not even thinking it could be my ustvnow account interaction.
Thanks.