Kodi 17 issue

Stoofer

Moderator
Staff member
Apr 18, 2015
674
0
0
Wales
Oh come on - how is anyone on Earth going to be able to give you an informative helpful answer that will get you back up and running when supplied with that?

But I'll give it the old Welsh try.....Have you tried turning it off and on again? And if that doesn't work jiggle it a bit.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,664
76
48
The Halls of Valhalla
Not sure. What did you do? Where did you get it from? What version of Windows? Did you have another version of Kodi installed before? Where did that version come from? Did it work well? What do you mean by "not running"? Is it starting at all or nothing at all pops up on the screen?
 

rick_ca

New member
Sep 7, 2016
6
0
0
I also just downloaded 17.1 to update my 16 kodi it downloaded ok I then set it up and told it to run kodi on finish the screen just blinks and nothing, now I find its also took out my kodi 16 that had been running flawless. I only downloaded to keep Kodi updated has anyone else ran into this. Im running windows 10 64bit 4gig ram on a laptop.
 
Last edited:

Meep

New member
Aug 23, 2016
692
0
0
Yes, I have seen similar problems with upgrade to 17.1, I believe a lot of it has to do with the skin setting incompatibilities (not confirmed just speculated right now)...

Did you install the Windows App version of Kodi or the Windows Program version of Kodi?

Chances are good you can recover your version 16.1 settings, by rolling back Kodi (how to do this will depend on what Windows version of Kodi you installed) the app version being many steps harder... From there you backup then try upgrading again after switching Kodi 16.1 to default skin and performing a backup and then upgrade...
 

dracozny

New member
May 27, 2015
11
0
0
For those of you that upgraded, check your log file. If you see a ton of failed 404 errors manually delete the repository files they point to and then restart Kodi. then go through and clean out any old repositories that were for Older versions of Kodi. Check my post from earlier today which gives a slightly better breakdown and the steps I took to repair it.
 

pandra

New member
Apr 10, 2014
6
0
1
Krypton 17.1 will not start on my Windows laptop. Never had a problem with 16.1. I followed the instructions from the "Install" section of this website. At the last dialogue box, I checked "Run Kodi" and then "Finish". The dialogue box disappeared, but nothing else happened. The new program appeared OK in the directory, so I clicked to start it from there. Nothing happened. I reran the installation program. This time I didn't check "Run Kodi", but after "Finish" I tried to start it like any other program. Nothing. I ran a cleaner on the computer and the registry and restarted my computer. I then tried to start Kodi. Nothing happened. I tried to run it from Program Manager; watching "Processes" I saw that kodi flashed briefly and then disappeared. Nothing else happened. I have checked my computer's security settings, and Kodi has full permissions to run.

In short, I've run every permutation of processes that I know how to do to start the program, but I can't get it to run.
 

egwphd

New member
Jan 23, 2013
28
1
3
ditto
i can't get tvaddons to operate properly on windows 7, 8 or 10, android 5.1 or my 2 shields

whatever happened Saturday was enough to make a fool out of me

i hope this will get straightened out in the next day or two

we all need to be patient until our expert friends figure out what we neophytes are having problems with
 

Meep

New member
Aug 23, 2016
692
0
0
Krypton 17.1 will not start on my Windows laptop. Never had a problem with 16.1. I followed the instructions from the "Install" section of this website. At the last dialogue box, I checked "Run Kodi" and then "Finish". The dialogue box disappeared, but nothing else happened. The new program appeared OK in the directory, so I clicked to start it from there. Nothing happened. I reran the installation program. This time I didn't check "Run Kodi", but after "Finish" I tried to start it like any other program. Nothing. I ran a cleaner on the computer and the registry and restarted my computer. I then tried to start Kodi. Nothing happened. I tried to run it from Program Manager; watching "Processes" I saw that kodi flashed briefly and then disappeared. Nothing else happened. I have checked my computer's security settings, and Kodi has full permissions to run.

In short, I've run every permutation of processes that I know how to do to start the program, but I can't get it to run.
IMO chances are very, very, very good there is a fragment of a previous Kodi install that is either corrupt or not compatible with Kodi 17.1 on the computer and this is what is causing the issue... If you are trying to 'upgrade' same thing, you have an addon or something from your existing Kodi 16.1 install that Kodi 17.1 just doesn't like and is causing it to crash...

The only suggestion I can really give is find the left behind fragment that is causing Kodi 17.1 to crash, but to be blunt you will likely spend more time tracking that down then nuking the entire thing and starting over... Don't just 'unistall Kodi' to do a clean install, you need to manually go into %APPDATA%\kodi\userdata and nuke all that, then go into the Program Files (x86) and nuke the Kodi directory... Can't say if there is anything in the registry that will need to be nuked... BUT before you do all this may I suggest you get a good backup of anything before you nuke it so you have the ability as a last resort to roll back to 16.1 as you work on a fix...
 

SilverTrove

New member
Feb 21, 2016
13
0
0
Really? I'm having the exact same problem and I can't believe I have to do all that to get the updated version to run. I am also running Windows x64 but on a desktop computer. Is there another way? Thanks!
 

Meep

New member
Aug 23, 2016
692
0
0
I have no idea if there is another way, as I have no idea what the 'actual' cause is or if it's universal across different OS systems or what not... This is really a problem for the official Kodi developers, but since everyone on this site uses third party addons that will cause 'our' pleas for official support to go unanswered, someone is going to have to replicate the failure with official Kodi addons only and then approach the Kodi developers...

Or maybe someone here with more time will find the culprit so it can be easily fixed...
 

DGM

New member
Aug 20, 2014
45
0
0
But I'll give it the old Welsh try.....
Well, there's the problem right there, you are supposed to give it the old Scottish try, geezz.

In this thread, Meep said it quite well...(and RavRob in another, and others in other threads)

"The only suggestion I can really give is find the left behind fragment that is causing Kodi 17.1 to crash, but to be blunt you will likely spend more time tracking that down then nuking the entire thing and starting over... Don't just 'uninstall Kodi' to do a clean install, you need to manually go into %APPDATA%\kodi\userdata and nuke all that, then go into the Program Files (x86) and nuke the Kodi directory... Can't say if there is anything in the registry that will need to be nuked... BUT before you do all this may I suggest you get a good backup of anything before you nuke it so you have the ability as a last resort to roll back to 16.1 as you work on a fix..."

I would add that it will could help (and won't hurt) if you run CCleaner registry cleaner. Don't go manually into the registry unless you know what the hell you are doing (I remember my first time playing in the registry, hahahahahahaha, what a disaster that was).

Good luck folks.
 

rick_ca

New member
Sep 7, 2016
6
0
0
sorry for delay in getting back on this I finally got Kodi 17.1 to work here is what I had to do
1 remove old kodi I used revo unintaller
2 download Kodi from Kodi webite and install
3 download indigo from tvaddons
4 reset new Kodi kin to look like kodi 16
5 setup my trakt account again
6 sit back and enjoy tv with a beer
Hope this helps
 
Thread starter Similar threads Forum Replies Date
D NVIDIA SHIELD 8
T Kodi Support 0
T Kodi Support 2