metahandlers update - beta test!

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
Hey guys,

I've pushed in some of my quick updates to metahandlers, mainly rushed this to fix the current errors caused by IMDB changing the names of some of the keys returned

Also:
- returning Year for TV Shows
- ensure episode # is returned as an int in all scenarios

If I could get some help on beta testing this one it would help speed getting this out faster, I've changed version # to a beta numbering to not mess us up for release (1.0.0.1)

https://github.com/Eldorados/script.module.metahandler


I had a couple other things I was working on to fix up some logic around tv shows, but pushed aside for now to get a fix out
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Ups maybe spoken to soon I get script errors on lastest and recently under tv shows when it reach around 20 something. Works fine with movies.

Edit: Again spoken to soon I get them randomly. I deleted the cache before installing gonna try again maybe the database download corrupted or something.
 
Last edited:

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
Ups maybe spoken to soon I get script errors on lastest and recently under tv shows when it reach around 20 something. Works fine with movies.

Edit: Again spoken to soon I get them randomly. I deleted the cache before installing gonna try again maybe the database download corrupted or something.
K, can you post up some logs with the errors? I figured I missed something in the tvshows when adding the year field

Everyone else - this is strictly beta testing, so know what your getting into if you install!
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
I posted one above. The error only happens in movies after it has happened once in tv shows.
If I restart XBMC movies just takes of where it left with no errors, but the tv show-->latest gives a script error right away like it has hit a particular item and will not go on from there. And like I said if I restart XBMC and go to movies or goes to movies from the beginning: no errors at all.
 
Last edited:

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
K I see it, doesn't like my date parsing thing when it's a None value.. gotta add more error checks!

I'll post when I've updated github again
 

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
K, just pushed in a quick fix for the log tuxen provided, thanks!

@Bstrdmkr - or anyone else, if you are reading can you run a pass on 1Ch**nel? An empty DB would be best to test with

I still need to add the tv show Year field to the db, but I think I'll hold that off for later, just want to get this fixed release pushed out
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
All seems to work in Ic*f*lms now. However 1Ch**nel not so good. ;/
log: http://pastebin.com/3TCpTNpv

Movies fallback to no metadata, In tv shows script error upon every entry.

In the log I enter movies first it seems like it retrieves (from the speed) but get no meta shown. Moves on to tv shows gets a couple of script errors when trying to enter varius entrys. And then exit.

PS this is latest beta of 1Ch**nel. Funny thing is the prwvius beta metahandler seemed to work with 1 channel. (I will check again)
 
Last edited:

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Last beta works fine with 1Ch**nel metadata in the movie section, but in the tv section same error as now script error upon all entry's.

Edit: Cleaned db every time I tested.
Edit edit: Actually the old version behaves in 1Ch**nel exactly like Ic*f*lms did. The new does not though.
 
Last edited:

Eldorado

Moderator
Staff member
May 7, 2012
990
0
16
K found two items, all related to tv shows - this is where I'm most concerned as it's had the most changes to, movies just needed the new imdb field names

Episode and Ratings weren't always being sent back in their proper formats

Just pushed in my latest changes with a new version #.. can you re-test?

So far it's working good for me on Ic*f*lms and latest 1Ch**nel beta
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Nope.. As umOuch said you are the man!
Can't provoke any errors anywhere anymore, tested Ic*f*lms, 1Ch**nel, and 1Click Movies from anilkuj and they all work great!!

Once again great job Eldorado.. Thanks a lot.
 

jas0npc

Banned
May 5, 2012
2,449
0
0
UK
I have installed in this on to my ATV2, but on 1 channel tv series - most popular, the search gets to 5 out of 24 items and the script errors out, here is my pastbin log of xbmc.log http://pastebin.com/TdEhNkNV
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Not to annoy you in any way but just to be sure. Did you clear out your database by deleting /userdata/addon_data/script.module.metahandler/ folder first. And last but not least get the lastest version of beta metahandler (7hours old or so) plus latest beta 1Ch**nel. Because I can not replicate this no matter how hard I try. And it sounds like the error with the previus metahandler beta or a corrupt database created by the last beta. Like Eldorado writes an empty database would be the best to test with.
 
Last edited:
Thread starter Similar threads Forum Replies Date
S Amazon Fire TV 0
W Video Addons 5
E Addon Development 52