My Experience with MyGica A520E Dual Core


New member
Sep 26, 2013
I have been loyal to my trusted ATV2 and they have served me well, but with the end in site for this workhorse of a box, I ventured out to see what will be my replacement. My first stop was the Mygica A520E.

I started off the day running xbmc 12.2 frodo (comes packed with it) and was reasonable, but I found a lot more buffering than on my atv2.

i decided to try to load kodi, but when I loaded the files it was on gotham 13.2 for some reason. Still a stable build, i decided to give it a shot, but unfortunately, I could not connect to my wifi network no matter what I tried.

The only spot I could connect from is Network-Manager under programs, but it would not show my access point. Very weird, since when I was running android, there were over a dozen from my neighbours.

Needless to say, after messing with it for hours, and googling for answers, still no connection. I re-flashed back to android and will give it one final test before I get a refund.