Ouya and Gotham issues

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
Hello everybody,
I would like to ask any other Ouya owners if they have install Gotham on their boxes.
Cause I get 2 strange annoying popups and I don't know how to get rid of them.

After installation and when I enter XBMC after a while there are 2 popups,one window for search and when I close this then after a while the second one that is the popup for the Youtube settings...

anyone come across the same?

thanks in advance...
 

josh3794

New member
Jan 20, 2013
126
0
0
Are you opening an addon when this happens? Some addons use youtube and that popup comes up usually the first time youtube is accessed on the box.
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
I have also thought about that but nope...

I have tried it also after a clean install and with no addons or repos installed...

same thing happens...
 

xiaNaix

New member
Apr 16, 2014
34
0
0
Sounds like you previously had an XBMC addon installed that wasn't completely removed when you un-installed. Get in there with adb or ftp and make sure all XBMC related folders have been completely removed.
 

josh3794

New member
Jan 20, 2013
126
0
0
Uninstall xbmc then In the ouya file directory under Android>Data delete the org.xbmc.xbmc directory. Reboot the machine and xbmc will be wiped from the machine.
 

tuxen

Banned
Mar 23, 2012
2,235
0
0
Denmark
Yep hard delete the profile some files could have been locked when uninstalling. The popup once for YouTube settings first time it's used is normal, just press ok or set your preferred settings first. Heh
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
ok here I am...

after a lot of tests and thorough testing I must say that strange and annoying things keep coming on my Ouya and the Gotham RC1 instance...

At first steps everything was just fine...

I have done all the things you have suggested...

then the annoying popups started to appear...one after the other...

most of them are related to "search" function...strange thing is that now the problem relates to more than one addon...

also the settings window from youtube keeps coming...and no matter what user/pass I set in there,I can't log in...

another matter is the "View" thing...whatever view I set it keeps changing by its own...well frankly when you first enter the list it is on the view I have set,after a few seconds it changes but when I exit and enter again the loop keeps coming...

is there sth that I could do to describe the problem better or a log that this can be seen?

the skin I use is Confluence

sorry but English isn't my mother language and I 'm trying to do my best...

edit: the same install on my Ouya (more or less) with SPMC 12.4.1 and Confluence Modified runs like solid rock...
 
Last edited:

rextoba

New member
Apr 30, 2013
137
0
0
Manitoba, Canada
This a video for a youtube login fix. I have 2 Ouyas both running Gotham Nightlies. I update daily and have done the youtube fix. I have no issues with pop-ups. I find the Gotham builds run better use them on all my other androids. Haven't switched with my Windows builds yet though.

https://www.youtube.com/watch?v=AbESS3Japo8

I use only a handful of add-ons from here and only 1 other from elsewhere and that's it. I use confluence also but can't help with your view problem as I haven't had any issues like yours. Good luck with the Youtube fix!
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
thank for your reply...

I have tried to apply the youtube fix but with no luck so far...

it must be sth that I am doing wrong...can't have another explanation that make sense to me...

I ll try it again couple of times as far as it concerns youtube fix...

if anything different occurs I will share it with you...
 

josh3794

New member
Jan 20, 2013
126
0
0
If it were me I would do a factory reset on the box and start over. Sometimes android can get corrupted in strange ways and cause apps to misbehave.
 

tahyti

New member
Feb 12, 2014
42
0
0
As is a factory reset on Ouya let a lot of things still on the Ouya.
If your problem is still there after a factory reset, you will need to boot to recovery and 1) reset to factory and 2) wipe the partition cache.

Several way to do so, the easiest way is to root your ouya and install ouya mod collection. Once there, you'll be able to rebot to recovery.
You might need an USB keyboard to lauch the recovery, as it require you to push the 'Home' button once you see the red !

Once everything is wiped, I do not recommand to root or do anything else besides installing the latest Gotham nightly.
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
well I would do that willingly but I have just put the stable release on pc too and I got similar strange problems with popups...

I feel that the advice sounds like do a format to pc also to get it running smoothly...

I strongly disagree but if there is no other way to fix it and I am the exception from all the others users probably this is what I will have to do at the end...

I ll keep searching and testing before the final solution...
 

mj71

New member
Jan 13, 2013
3,706
0
0
Im curious lol
What are these popups you keep seeing all the time?

Any way to take a photo and upload it here?
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
I ll try to explain you mj71 and if I can't be well understood or good in description I ll try to upload some photos...

in Ouya I have the box waiting and doing nothing,then randomly there will be the popup for youtube settings (everytime not just once),popup for urlresolver (everytime and urlresolver also came up on pc),also I get popup windows of search service (if I click done with blank field then I get the error from the addon,sometime is the Icefilm,the other is the 1Ch**nel,even the GoTv of Lambda came up)...

I tried to fix the youtube fix as someone pointed me earlier with no luck...

Is photos going to help you more?
 

mj71

New member
Jan 13, 2013
3,706
0
0
Ok i dont have an ouya but maybe someone with this device may be able to help if they have seen this happen on their box

Photos might help.Its always good to have as much information as possible

Ive not heard of this before with random stuff just keep popping up on the screen so would be good for someone to help you

And its happening on your pc also? This is strange :confused:

Did you ever install anything not from hub or .org?
 
Last edited:

showgun

New member
Dec 23, 2011
3,209
0
0
To Your Left
I have an OUYA and have never seen these issues. If I were you... I would do a complete factory reset of OUYA. THEN INSTALL XBMC from the Discover store. Then ONLY INSTALL ADDONS from XBMCM.ORG or XBMCHUBM.COM
 

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
Thanks for the answers guys and your help...

to be sincere I am kinda hesitating to do the clean install cause SPMC and Confluence Modified for my needs are money in the pocket but it seems that I have no other choice in order to clarify what could be the problem...

Showgun Discover Store contains stable Gotham?

Mj71 I find it also strange and I ll try the clean install first in my pc...also I haven't install anything besides repos and addons from here and through the Fusion ftp...

hopefully I will find or discover what is the problem and let you know,if you don't find it first for me...
at a point I thought the problem could be the Ouya controller or the Yatse remote but I was held back when the urlresover setting popup appeared on my computer...

I ll keep testing and we ll see what will occurs...

edit:just a small update

I have tried to watch an episode of Hawaii 5-0 on the Gotham instance (cause through Frodo-SPMC version couldn't find any subs to fit and that's the main reason that makes me want to step over-better subs support-) and believe me guys it was an anxiety test-fusbaaaaa- lol...

while viewing the episode first popup of youtube settings,2nd urlresolver settings,then window of search->hit done at once script failed:Ic*f*lms,then several popups one after the other like I was extended searching sth,left all of them blank then script failed:1Ch**nel,after that occasionally with no popups now at the bottom of the screen messages of scripts failed like GlowHd,Gomovies etc...while viewing the episode...

just saying...

hopefully tomorow I ll find some time to make a factory reset and clean install but I am not promising though...

my small daughter may have other plans for the evening...and you can't say no to a 19month old small little tiny human...:p

I ll be around and thank you for your time...
 
Last edited:

LordElrond

New member
Dec 22, 2013
29
0
0
Kerkyra,Gr
well another update...

still didn't -yet- approach the clean install but I would like to provide some screenshots from my pc...

https://www.dropbox.com/sh/m8ae2x6s5b7p5w5/YbZH9knMCM

story goes like that: I have opened xbmc on my pc (windows 7) and let the instance running. After a while (don't know exactly) went back to check it...

I found the things as shown...every screenshot is sequential closing of the selfopening popups...

hope it helps you somehow or otherwise I must be an exception...

Similar things happening to Ouya as I have tried to explain you...

I suppose if I do the same the popups probably -if not for sure- will be different...the music video as an example was a first timer...

if there is sth else that I could do to provide more help please tell me so...