Rasp pi b+ pure static noise from analogue output.

DankNasty

New member
May 16, 2012
120
0
0
To anyone that has a b+ would you mind checking your audio analogue out. I just found out mine delivers pure static and when I took this to the rasp pi board so did a number of others. As it's analogue most people probably havnt tried it or don't care but I'd like to know if it's a major defect.
 

ute

New member
Dec 16, 2012
460
0
0
Mine is good , but as you said never checked it before

Also I got one of the first builds so that might make a difference
 

bullsboy

New member
May 28, 2012
392
0
0
Derbyshire, UK
I thought I'd read that was one of the improvements they'd made on the B+? I get static at low volume on my model B and was thinking of buying a B+ to resolve it.

Can you keep us all informed if there is a root cause/fix?
 

Frederick_99

New member
Sep 18, 2012
452
0
0
UK
I use the dual audio output facility on my xbmc set up on my Pi (B) and use the audio analouge output for wireless headphones.
As bullsboy has mentioned I find that i have to increase the volume to reduce static and once done works very well

So you might just try turning up the volume on the B+ to see if that helps
 

Dam0

New member
Aug 24, 2013
28
0
0
are you getting audio signal AND white noise? or just the noise?

if you do not get pi generated sounds, maybe try adding the following to config.txt

Code:
hdmi_ignore_edid_audio Pretends all audio formats are unsupported by display. This means ALSA will default to analogue.

 hdmi_ignore_edid_audio=1
 

utterme

New member
Feb 24, 2015
1
0
0
I'm using analogue from B+ to AV surround amp. Also noticed white sound in the audio streams.

Here's what I did that eliminated the white noise.
Turn volume all the way up on pi, then turn the volume down on AV amp till white noise is gone.
 

kofigc

New member
Apr 16, 2014
2
0
0
Go to your settings and set "keep audio device alive" to off... Done this on my pi to eliminate constant static / white noise that played when no sounds were on at all (even when GUI sounds turned off) or during playback. It says some sounds might be missed because the audio device isn't kept awake or alive but I've never had an issue
 

lizardkng

New member
Dec 17, 2014
40
0
0
If youre using one of those analog cables from amazon, like this one...

You have to reverse 2 of the cables, as the first reviewer states.

For those that are buying this cable for a Raspberry Pi, be warned that the color of the plugs does not represent the plug format that you should follow when connecting your devices. For Raspberry Pi B+ users, the red plug is your video so plug that into yellow on your display or television. The yellow plug is your right audio so plug it into your red plug on your sound device. The white left audio cable is correct for RPI users.