Real Debrid HD Links

jdoe

New member
Mar 22, 2018
2
0
0
I am using Kodi on a Windows 10 HTPC with 8gigs of free memory and a 100mbs internet connection.

I have had a Real Debrid Premium account for 2 years without a single problem until January, 2018.

I am now receiving very few Real Debrid High Definition Links and none of them will play consistently.

All Real Debrid HD Links will either not play or play for 10-30 seconds and freeze on the buffer wheel.

I performed a Fresh Start on Kodi 17.6, setup Advanced Settings addons, updated the URL Resolver,
re-authorized Real Debrid, reset Read Debrid function cache but none of these steps solved the issue.

I am seeking help from anyone on the TVAddons Forum who has a tried and true solution that works.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,584
59
48
The Halls of Valhalla
You should post a log capturing the buffering problem. Reading what you did to fix the problem, it seems you have done everything right and everything I could recommend. A log might show the problem. NOTE that I can't read logs so a more knowledgeable person will need to pop in and see that the problem is.

A friend had similar problems. She installed F4MTester and the problem was gone according to her. I didn't think f4mtester had anything to do with links other than live links but it is still worth a try I guess.

Other than that, I can be of no help.
 

Maverickz

Member
Dec 20, 2013
40
0
6
I was having the same problem with all links, even RD links buffering and watching the network speed they never topped 2 MBps which is obviously too slow. I didn't have this problem on older versions of Kodi/XBMC. Even asking on these forums NO ONE had any idea why. I spent a lot of time digging, hunting and experimenting. I finally found a solution, at least for me. It turned out that Kodi was artificially limiting the available bandwidth it was able to use.

The solution is to create a file called "advancedsettings.xml" in the "\Kodi\userdata" folder (location will vary by Operating System) but in Windows 10 is should be in "C:\Users\YOUR_USER_NAME\AppData\Roaming\Kodi\userdata" (unless you installed the MS Store version)

Once created open the file in a text editor (notepad works) and paste in the following, save it and restart Kodi:

<advancedsettings>
<cache>
<readfactor>30</readfactor>
</cache>
</advancedsettings>
This value controls how fast Kodi can refill the cache and the default is 4. You can play with the value. If you set it too low you will get lots of buffering, if you set it too high it could potentially use all your available bandwidth.
 

jdoe

New member
Mar 22, 2018
2
0
0
MAVERICKZ, Thank you for having the final resolution to my Real Debrid HD problem.

I deleted the advanced settings addon & advancedsettings.xml file already on my PC

then recreated the .xml file with just the buffer factor as you suggested and it worked.

It has been quite a nightmare trying to find a resolution, I appreciate the great help!!