[RELEASE] TVPlayer.com (Discontinued)

Status
Not open for further replies.

itekweni

New member
Jun 5, 2015
8
0
0
JNRW thanks for reply if I use the tvplayer.com via browser it works a charm but running it via Kodi as I have been doing for some time and as I said since the 13th it has been giving errors and i am not sure how to check the actual addon xml to see if there is some changes to be made to it so that I can view it in Kodi
 

JNRW

New member
Oct 13, 2014
151
1
0
JNRW thanks for reply if I use the tvplayer.com via browser it works a charm but running it via Kodi as I have been doing for some time and as I said since the 13th it has been giving errors and i am not sure how to check the actual addon xml to see if there is some changes to be made to it so that I can view it in Kodi

It sounds as though a bit of developer input is required. Unfortunately this is a bad time of the year for such voluntary work. I am sure it will be rectified as soon as possible. My admiration for these guys knows no bounds.
 

itekweni

New member
Jun 5, 2015
8
0
0
JNRW thanks for reply and hope it does get a fix soon failing that i will have to bin addon :-(
 
Aug 1, 2017
65
1
8
I am sorry guys, I have been away for the Christmas/New Year period. I knew this add-on was broken, but I have not had time/internet/whatever to do much about it.

The good news is I know the error, I have fixed the error and I will be pushing an update within the hour.

Sorry for the hassle, thank you for your patience.
 

itekweni

New member
Jun 5, 2015
8
0
0
BludhavenGrayson no need to apologise because one has to have his own personal life which comes first and thanks for a great addon
 

rikkitic

New member
Oct 13, 2017
8
0
0
Here is what I don't understand. The add-on works for a few sites, like Russian Today and BBC News, but it does not work for others, such as CNN and Dave. Yet these all work on my pc browser. What is the difference?
 
Aug 1, 2017
65
1
8
Here is what I don't understand. The add-on works for a few sites, like Russian Today and BBC News, but it does not work for others, such as CNN and Dave. Yet these all work on my pc browser. What is the difference?
I can't look into your issue without a debug log.

The two channels you mention don't work for you, do work for me (in fact the only reason I made this add-on was for Dave). Are you signed in to your TVPlayer account in the settings? There are several channels that require you to be logged in to watch.

However, there are channels like the ones in the Five family that do not work within Kodi. This is because they use a different, yet-unbreakable, DRM.
 

Mr T

New member
Dec 27, 2017
3
0
0
I had an issue, on 2 seprate Kodi build which both showed a Python array offset error. Is this the bug you are fixing?
 
Aug 1, 2017
65
1
8
I had an issue, on 2 seprate Kodi build which both showed a Python array offset error. Is this the bug you are fixing?
I am not aware of any bugs. I have just gone through and checked a dozen channels, including Dave and CNN, and they all worked.

If you are experiencing any issues please upload a debug log.
 

Mr T

New member
Dec 27, 2017
3
0
0
I am not aware of any bugs. I have just gone through and checked a dozen channels, including Dave and CNN, and they all worked.

If you are experiencing any issues please upload a debug log.
Which I would if I wasn't also getting an error when I try a log upload (again on both boxes)
I can paste a snippet here if it helps
 
Aug 1, 2017
65
1
8
Which I would if I wasn't also getting an error when I try a log upload (again on both boxes)
I can paste a snippet here if it helps
If you can access the log file on a PC you could copy and paste the contents to pastebin, if that's ok?

When do you get the error? When trying to play a channel?
 

rikkitic

New member
Oct 13, 2017
8
0
0
Thanks for the quick response. I will post a log as soon as I can get to it. I am new to this site and I'm not sure what the correct method for posting a log here is. I have not created an account yet because I am used to the free sites on TV Player working without one on the pc.
 
Aug 1, 2017
65
1
8
Thanks for the quick response. I will post a log as soon as I can get to it. I am new to this site and I'm not sure what the correct method for posting a log here is. I have not created an account yet because I am used to the free sites on TV Player working without one on the pc.
Try with a created account. The service does have different login/channel availability from device to device. Accounts are free (paid channels do not work in Kodi).

I get the error when I try to play. I can navigate to the chanels OK.
https://pastebin.com/JY3iLAnt
Can you check what version of the add-on you have installed? It looks like an old version, and should be version 1.0.1. Do you have my repository installed? If not, install it, and it should auto-update.
 

rikkitic

New member
Oct 13, 2017
8
0
0
I can't look into your issue without a debug log.

The two channels you mention don't work for you, do work for me (in fact the only reason I made this add-on was for Dave). Are you signed in to your TVPlayer account in the settings? There are several channels that require you to be logged in to watch.

However, there are channels like the ones in the Five family that do not work within Kodi. This is because they use a different, yet-unbreakable, DRM.
OK, I have posted a short log to pastebin. I tried Dave and CNN as previously and both returned errors. As a check, I then tried BBC News and it worked normally. When looking at the log, I notice there is a demux error on the two that failed, but not on the one that worked. Don't know what the significance is.

I think this should be sufficient, but if it is not, just let me know and I will try to do whatever is necessary. Thanks very much for your trouble on this.

https://pastebin.com/Y4BvA7wy
 

rikkitic

New member
Oct 13, 2017
8
0
0
Try with a created account. The service does have different login/channel availability from device to device. Accounts are free (paid channels do not work in Kodi).



Can you check what version of the add-on you have installed? It looks like an old version, and should be version 1.0.1. Do you have my repository installed? If not, install it, and it should auto-update.
Just saw your latest reply. I will do what you suggest. In the meantime you have my log if you want to look at it. I will let you know if anything changes.
 

rikkitic

New member
Oct 13, 2017
8
0
0
Just saw your latest reply. I will do what you suggest. In the meantime you have my log if you want to look at it. I will let you know if anything changes.
Well, this kind of sucks. I am in fact running version 1.0.1. I set up an account and it didn't make any difference, except that now Windows has started crashing. I hope you can find something in the log file. Let me know if there is anything else I can do.
 

Mutagen

New member
Aug 7, 2016
4
0
0
Hi I have a TVplayer account and a vpn, the addon has the information of the free account, all was working well but about 3 hours ago I have no longer access to any channel, the same happens with the other tvplayer addon but in the other I get the information that I have to fill in the information of the free account in the addon settings even if that information is already added. Through firefox I got in to the TVplayer webpage I accessed my account I was able to watch the free programing. There seems to be some other problem hope it can be fixed.
BTW in the notice of the other addon it states "HTTP Error 401: Unauthorized" hope that helps
 
Last edited:
Status
Not open for further replies.