Rpi 2 Offical Openelec realeses with updated librtmp

invisable

New member
Feb 23, 2013
767
0
0
UK
So what is the exact process of install this ??

I did do a test on My tablet versus the Pi, and there were many more working links on my tablet with update Lib
Download the latest tar file for your system on a PC.

Since you have just set up your ftp client...

Open up your ftp client on your PC and navigate to /storage ( this is usually the default location when you first log in)

If there's not already create a folder called .update "the dot is important also make sure it's all lowercase"

Transfer the complete tar file to the .update folder.

Reboot and it will automatically install.
 

DJB

New member
Nov 2, 2014
409
0
0
If you want to install supercelerons latest "May patches" to Kodi 15 Isengard you will need to follow milhouse's instructions here.
librtmp - Help Thread
U Da Man, I'll check this when I get home from work, cheers. I believe I have an .update folder already created, so I'll put it in there, thanks again for all you help and advice

I'm going to stay with 14.2 for now, and give it time for Isenguard to be out and tested more first.

Since I'm on the latest OE, I think 5.0.8, then this is the one I put in the folder, just want to make sure not to make a mistake. see below

Do I simply put it in the folder as is, or does it need to be unzipped ??

Code:
http://www.mediafire.com/download/rwdab9yoazgb6wo/OpenELEC-RPi2.arm-5.0.8.tar
 
Last edited:

DJB

New member
Nov 2, 2014
409
0
0
You can put the tar file in as is.. Openelec will extract it for you :)
I've decided to wait for the 15.0 tar release, instead of updating twice. I assume when it'll be release it'll be posted in Superceleron Media storage folder ?? And I'll have to do the same, simply install the Tar file in the .update folder and reboot ?
 

invisable

New member
Feb 23, 2013
767
0
0
UK
Yes it will be exactly the same method.

When openelec release version 6.0.0 I unsquash it and re-compile the openelec. tar with the new Librtmp.so.1 file from supercelerons folder.
 

DJB

New member
Nov 2, 2014
409
0
0
Yes it will be exactly the same method.

When openelec release version 6.0.0 I unsquash it and re-compile the openelec. tar with the new Librtmp.so.1 file from supercelerons folder.
Kool let me know when you do so, you're the best, cheers
 

steveuk23

New member
Aug 9, 2015
30
0
0
Hi guys
Sorry for the noob question as I've had my Rpi2 running nice now for a while on openelec.
But I've never heard of this lib file before and just been googling it and see its to do with streaming.
I'm still on 5.0.5 helix as my setup seems to work OK so thought don't want to risk updating bed things messing up!
I use all the usual addons and football streaming ones and most work OK but none of the acestream ones though is this what this files for?
Sorry for sounding thick 😊
 

invisable

New member
Feb 23, 2013
767
0
0
UK
It's just a file that is needed to play back streams, the one included in the official builds is older and doesn't include the latest patches that some streams require.
This means some won't play with the stock version.

Ive read that there may also be some legal streams now from the official Kodi addons that now require some of the latest patches.

Same goes for anyone reading, if your setup is working then there's no need to mess around with it, if your finding lots of streams aren't then consider updating :)
 

invisable

New member
Feb 23, 2013
767
0
0
UK
Acestream is a different matter, it doesn't work on Linux Arm devices at the moment.. enen92 is possibly working on a fix, but i understand it's a hard task so don't hold your breath ;)

For information on his updates I would recommend reading the last few pages of this thread
http://forum.kodi.tv/showthread.php?tid=201894
 
Last edited:

steveuk23

New member
Aug 9, 2015
30
0
0
It's just a file that is needed to play back streams, the one included in the official builds is older and doesn't include the latest patches that some streams require.
This means some won't play with the stock version.

Ive read that there may also be some legal streams now from the official Kodi addons that now require some of the latest patches.

Same goes for anyone reading, if your setup is working then there's no need to mess around with it, if your finding lots of streams aren't then consider updating :)
Thanks for the reply.
I will just leave mine for now then seen as most things play OK.
Thanks for the acestream link I'm already actually following that and seen his plexus idea which looks great.
Nice forum this only found it yesterday I've been using Kodi's and openelec mainly.
 

invisable

New member
Feb 23, 2013
767
0
0
UK
is there no diskimg file for pi 1?
No I havnt got a original Raspberry pi to test with anymore, from testing various streams it appears that the default stock openelec librtmp in 5.95.5 is the same as the updated librtmp in 5.0.8 anyway.

So if you just install the official openelec 5.95.5 from the Openelec site you should be fine.

If you want to use 5.0.8 just burn the 5.0.8 img from the Openelec site and put my 5.0.8 in the update folder and reboot
 

thecochise

New member
Oct 23, 2014
2
0
0
The librtmp.so in 5.95.5 doesn't have any of the KSV updates so should be the same as official 5.0.8.

Users are better off installing the milhouse library hack so that the latest librtmp.so library can be used with any build, including official releases and as-yet unreleasd builds. Relying on someone to find the time and produce a custom unsquashed/squashed build just for librtmp.so is a PITA.
 

streamsfine

New member
Jan 16, 2014
14
0
0
Thank you invisable for making updates for us to use. Do you have any recommendations for advancedsettings for pi2 on an SD? Thank you.
 

invisable

New member
Feb 23, 2013
767
0
0
UK
No worries @streamsfine.
But thecochise is right though, it probably would be easier to use the library hack method, especially if they want to play around with retroplayer builds.

Anyway in regards to advanced settings I generally don't use any.
Not network settings anyway..
I've found trying to improve buffering/cache can sometimes lead to slight problems when using other addons.