sound issues with android box

chippy10

New member
Jan 21, 2016
19
0
0
Northants UK
Not sure if this the right area, but here goes, sorry if I've put it in the wrong place!!

Hi,
Although I'm delighted with the quality of the results from the add-ons that I have ( U*T*rk, Genisis etc) the one thing that bugs me is the sound issue. It doesn't matter what add on I use, the result is the same i.e poor sound, as if the sound is mono, and everything comes out from one speaker, in fact, i'm more than convinced it IS mono that comes out of my TV!
The setup I have is this,
there is a HDMI cable that goes directly to the TV, there is an Ethernet cable that provides me with the the service, and a power connector. There is a socket which is marked SPDIF, and another marked AV. I have only coaxial available and not optical, as the TV is a few years old. Would finding a cable be useful for sorting out the poor sound issues? Like a SPDIF to coaxial if there is such a thing? If I did find such a cable, would I need to change any of the settings in the android box?

Cheers for your help

Graham
 

skyhigh

New member
Jan 11, 2015
54
0
0
check your settings on the android box itself, its possible you have it set on mono, rather than hdmi..
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,584
59
48
The Halls of Valhalla
With an older TV you likely don't have Coaxial or SPDIF in anyway so a cable wouldn't help. It would work if you had a home theater system.

The HDMI to TV should work at least in Stereo. As directed by Shyhigh, check the sound settings in Kodi.
Settings>System>Audio
Change your Audio Output Device to Direct sound Default or Direct sound Speakers
Try different settings until you are happy with the outcome.
 

chippy10

New member
Jan 21, 2016
19
0
0
Northants UK
With an older TV you likely don't have Coaxial or SPDIF in anyway so a cable wouldn't help. It would work if you had a home theater system.

The HDMI to TV should work at least in Stereo. As directed by Shyhigh, check the sound settings in Kodi.
Settings>System>Audio
Change your Audio Output Device to Direct sound Default or Direct sound Speakers
Try different settings until you are happy with the outcome.
Cheers, I'll have a look at the settings and go from there!
Graham