Sound jitters on Stick after opening Kodi

badgiec

New member
Mar 14, 2014
8
0
0
Bit of a strange one.....

When I power up the Fire Stick trailers will play normally and other apps play fine too.

But when I open Kodi and try to play an AddOn the sound jitters. Then when I exit Kodi and play the trailers and other apps again the sound continues to jitter.

To make things more complicated the issue doesn’t happen when I plug the stick into my main TV. It only happens when plugged into a TV which is much older (more than 10 years old).
Not sure if the age of the TV is a problem but I’m using the TV without any issues with the set top box of a local entertainment provider.

Any ideas why this would be happening? I’m using Kodi 17.6.
 
Last edited:

RavRob

Moderator
Staff member
Nov 21, 2012
6,665
76
48
The Halls of Valhalla
Sorry, not sure about why this would happen. I would think it is a TV problem since it works well on your newer TV. Have you tried adjusting the sound settings in the Kodi settings? I can't think of anything else. Sorry.
 

badgiec

New member
Mar 14, 2014
8
0
0
Thanks RavRob. I tried changing audio settings in Kodi as well as the limited audio options on the stick but had no positive outcome unfortunately.

Yes the TV seems to be part of the problem but just seemed strange that it only happens after opening Kodi. If i start the stick and watch another app like Nextflix or BBC iPlayer there are no issues. But once I open Kodi all apps I use afterwards are affected until I restart the stick.

I’ll try a different HDMI cable to see if that makes a difference as it’s a different cable I’m using when connecting to the other TV.
 

badgiec

New member
Mar 14, 2014
8
0
0
Fixed!!!

I seem to have sorted it by changing the Video Resolution setting on the stick (Settings->Display & Sounds->Display->Video Resolution).

I changed it from “1080p 60Hz” to “Auto” and sound in Kodi and all other Apps on the stick is working fine again!!

Glad I don’t have to splash out on a new tele to enjoy Kodi from the other room!!

Thanks for your replies & interest RavRob. Hopefully this post will be of help to someone who hits the same issue.

Still don’t know why running Kodi would have initiated this kind of issue on the stick on one specific TV and not the other TV. Must be something in the more intricate coding of the stick or Kodi and maybe the older TV wasn’t capable of handling that.
 
Last edited: