Bug Suddenly no sound when using KODI with Chromecast

Port Said Red

New member
Mar 14, 2016
10
0
1
Hi All

I guess this may not be the first time this issue has been raised but I couldn't find a thread that was relevant. I have a Lenovo laptop with Kodi (Jarvis 16.1) installed and I use the Cast Entire Screen option on the ChromeCast app to watch it on the TV mostly Ex**us but some Spor**dev*l. I was using at as usual yesterday with no problems, but today I am getting no sound.
I have tried everything I can think of including uninstalling Kodi, uninstalling the Chromecast app, updating Chrome, and resetting the Chromecast stick itself, none of which has had any effect at all.
I notice that the Volume control and the Volume application, keeps returning to zero each time I look at the sound settings when playing a file but changing that has no effect either. Has anyone got/had this problem and a possible solution?
 

NorthernPlumber

New member
Jun 13, 2016
4
0
0
Can you cast with a phone or another device and have sound? rule out the laptop. Change HDMI ports, check HDMI sound settings make sure they are digital
 

strike0408

New member
Nov 29, 2012
774
1
0
Canada
Hi All

I guess this may not be the first time this issue has been raised but I couldn't find a thread that was relevant. I have a Lenovo laptop with Kodi (Jarvis 16.1) installed and I use the Cast Entire Screen option on the ChromeCast app to watch it on the TV mostly Ex**us but some Spor**dev*l. I was using at as usual yesterday with no problems, but today I am getting no sound.
I have tried everything I can think of including uninstalling Kodi, uninstalling the Chromecast app, updating Chrome, and resetting the Chromecast stick itself, none of which has had any effect at all.
I notice that the Volume control and the Volume application, keeps returning to zero each time I look at the sound settings when playing a file but changing that has no effect either. Has anyone got/had this problem and a possible solution?
in kodi go to system/system/audio output/and then click on "audio out device" and try the different settings in there and see if that helps...
 

Port Said Red

New member
Mar 14, 2016
10
0
1
in kodi go to system/system/audio output/and then click on "audio out device" and try the different settings in there and see if that helps...
Thanks for the suggestion, I was playing with this last night. I noticed that when I connected my laptop to my portable soundbar via bluetooth that this became an option I could select. I don't see any option for my JVC TV though.... should I?
 

strike0408

New member
Nov 29, 2012
774
1
0
Canada
Thanks for the suggestion, I was playing with this last night. I noticed that when I connected my laptop to my portable soundbar via bluetooth that this became an option I could select. I don't see any option for my JVC TV though.... should I?
you should if you connect it to your laptop...
 

Port Said Red

New member
Mar 14, 2016
10
0
1
you should if you connect it to your laptop...
Well it is via chromecast? Anyway....

I am in a hotel tonight. I have a different chromecast stick and it's plugged into a different TV (obviously) I am still not getting any sound when casting the entire screen, but I am getting sound when I cast Youtube.
When I check the Audio on the file I am playing it says "Unknown Stereo" in the Audio Stream section, but it greyed out and gives no option tto change it. I have tried all the options under Audio in System too. :(
 

Port Said Red

New member
Mar 14, 2016
10
0
1
I have discovered the answer to my problem. My Chrome browser updated recently and apparently some of the "Chrome flags" are set differently. I needed to enable the flag #disable-audio-support-for-desktop-share
If you (like me) don't know how to do this. type chrome://flags/ into a chrome browser tab to see the list of all the tabs, I then copied in the #disable-audio-support-for-desktop-share line to find it, then clicked enabled and it's all hunky dory now. :)
 

Port Said Red

New member
Mar 14, 2016
10
0
1
Believe it or not I have an update for this.... If any of you are also unable to cast sound again, like I discovered on Friday. This is the solution.
It's all down to these damn CHROME FLAGS again. So before when my audio stopped working for no apparent reason I had to ENABLE. chrome://flags/#disable-audio-support-for-desktop-share and that fixed the problem.
NOW, strange as it may seem I have to DISABLE the same flag which then gives you a little checkbox to tick when you want to stream the entire screen.
It really is as ridiculous as it sounds, GOOGLE your left and right hands need a chat sometime!!