Try as I might, cant get Tv to work with PI via HDMI

Dunkle

New member
Jun 5, 2013
294
0
0
Its certainly an HDMI issue and one with the TV (as same Pi works on other TVs) but cant work it out

The TV in question is in our bedroom, its a rather old Sharp LC37RD2E which I know CANNOT do 1080p however it can do 720p and 1080i and does so from both an XBOX 360 and PS3 and also an XBOX ONE

However no matter what I put in the config of the PI the TV briefly shows the rainbow screen before "buzzing" and then fading the picture out (not too disimilar to what TVs used to do when the tube went) which I know happens if you try to feed the TV a 1080p signal. Thing is I belive I have tried EVERY possible setting to get it to not go 1080p

So as it stands I have to use the composite out and go that way

Any ideas ?
 

Dunkle

New member
Jun 5, 2013
294
0
0
So did I, and only when playing media etc would it go 720p, but no matter what I do as soon as I try and connect the PI with the TV via HDMI it has none of it and throws a wobbly

XBOX, PS3 even XBOX One will all work fine at 1080i or 720p so why I cant get Pi to do same is byond me
 

oso

New member
Sep 19, 2012
378
0
0
One thing to try is to turn off TV, unplug hdmi, plug hdmi back in, turn on Pi, then the tv last. I had thi sproblem before and it was the security handshake that was causing the problem. I guess u have tried force hdmi and the various other tweaks that can be found on the elinx site ?
 

mikeboffer

New member
Dec 3, 2013
3
0
0
My Pi outputs at 1080p (but the GUI is 720p which is unscaled to fit 1080 resolution). Maybe get it running on another TV that can do 1080p and make sure you set the Pi to 720p output and try again...
 
Last edited:

Dunkle

New member
Jun 5, 2013
294
0
0
One thing to try is to turn off TV, unplug hdmi, plug hdmi back in, turn on Pi, then the tv last. I had thi sproblem before and it was the security handshake that was causing the problem. I guess u have tried force hdmi and the various other tweaks that can be found on the elinx site ?
My Pi outputs at 1080p (but the GUI is 720p which is unscaled to fit 1080 resolution). Maybe get it running on another TV that can do 1080p and make sure you set the Pi to 720p output and try again...
Yep, both done, every possible variation of handshake various cables, various setups = nothing
 

splatee

New member
Aug 28, 2013
82
0
0
It may sound like a longshot but did you try changing HDMI cables? Did not see it mentioned. Also how long is the cable? I read somewhere that using a short HDMI cable like 3 feet sometimes causes handshake issues. Sounds strange but if all else is failing.
 

Dunkle

New member
Jun 5, 2013
294
0
0
Still struggling with this
My blu ray player works fine
The tv shows that as 1080i 60hz
How can I get same from pi ?
 

invisable

New member
Feb 23, 2013
767
0
0
UK
Im confused with this.
have you tried booting the pi without the config.txt ( just in case we are missing something)
You could rename it to oldconfig.txt
so you can easliy change it back.
 

Dunkle

New member
Jun 5, 2013
294
0
0
Im confused with this.
have you tried booting the pi without the config.txt ( just in case we are missing something)
You could rename it to oldconfig.txt
so you can easliy change it back.
according to http://elinux.org/RPiconfig, in order to output 1080i @60hz you should use:

hdmi_group=1
hdmi_mode=5

maybe also use

config_hdmi_boost=7
hdmi_force_hotplug=1

to get maximum signal strength.

Good luck!
With both these options, still the same, no signal
 

Quihico

New member
Jun 4, 2013
61
0
0
Strange...
Do you have an SD card with Raspbian installed? Or are you willing to make one?
With raspbian (or RASPBMC/XBian or anything but OpenELEC I think) you can get very detailed information about what your monitor supports by following the instructions at http://elinux.org/RPiconfig:
"
Your HDMI monitor may support only a limited set of formats. To find out which formats are supported, use the following method.
Set the output format to VGA 60Hz (hdmi_group=1 hdmi_mode=1) and boot up the Raspberry Pi
Enter the following command to give a list of CEA supported modes
/opt/vc/bin/tvservice -m CEA
Enter the following command to give a list of DMT supported modes
/opt/vc/bin/tvservice -m DMT
Enter the following command to show your current state
/opt/vc/bin/tvservice -s
Enter the following commands to dump more detailed information from your monitor
/opt/vc/bin/tvservice -d edid.dat
/opt/vc/bin/edidparser edid.dat
"
I'm rather curious what the results will be.
other suggestions @ http://elinux.org/RPiconfig are:

hdmi_ignore_edid=0xa5000080

hdmi_safe=1

or

hdmi_edid_file=1 (requires edid.dat present at root of sd-card).

If other devices manage to be displayed correctly then the pi should be able too, just a matter of finding the correct settings. I'm sure with the help of this forum it will work eventually.