Bug Ubuntu 16.04 LTS / KODI 17.1 Crashes [Big Time]

Mr.Grumpier

New member
Feb 27, 2017
2
0
0
I have downloaded and installed the most recent KODI update 2:17.1 on my laptop [16.04 since June 16], before worked OK - now disaster! The update was automatic, though, if I knew what was about to occur I should have deselected it.

I worked/guessed through advice on TVA Log Uploader, that came up with an error and crashed back to KODI splash screen.

I not only get a Kodi-crash log but a LINUX core dump! Can I go back to Jarvis, please? :mad:
 

VikingVic

New member
Mar 25, 2014
16
0
0
I have 6 boxes with 16.04 and 14.04 with the new Krypton that just do the same as you state. After the auto update I can not stop them from crashing. Some say JSON RPC is one of the problems.
Indigo fails. Ex**us crashes hard time, Pho*nix crashes. SA*TS, 1Ch**nel. Even addons from the KODI team!Something is severely wrong with Krypton and Linux right now and needs to get fixed fast!
I will try to put on some crash file details up here soon.
 

VikingVic

New member
Mar 25, 2014
16
0
0
Excepts from the log files with warnings or errors:

13:29:27.772 T:140179746580224 NOTICE: Running database version Addons27
13:29:27.777 T:140179746580224 NOTICE: Running database version ViewModes6
13:29:27.778 T:140179746580224 NOTICE: Running database version Textures13
13:29:27.779 T:140179746580224 NOTICE: Running database version MyMusic60
13:29:27.782 T:140179746580224 NOTICE: Running database version MyVideos107
13:29:27.783 T:140179746580224 NOTICE: Running database version TV29
13:29:27.783 T:140179746580224 NOTICE: Running database version Epg11
13:29:27.785 T:140180406970752 NOTICE: start dvd mediatype detection
13:29:27.895 T:140180406970752 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"

13:29:26.425 T:140180406970752 NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
13:29:26.425 T:140180406970752 NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
13:29:26.425 T:140180406970752 NOTICE: Default Video Player: VideoPlayer
13:29:26.425 T:140180406970752 NOTICE: Default Audio Player: paplayer
13:29:26.425 T:140180406970752 NOTICE: Disabled debug logging due to GUI setting. Level 0.
13:29:26.425 T:140180406970752 NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
13:29:26.425 T:140180406970752 NOTICE: CMediaSourceSettings: loading media sources from special://masterprofile/sources.xml
13:29:26.425 T:140180406970752 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:29:26.426 T:140180406970752 NOTICE: Loaded playercorefactory configuration
13:29:26.426 T:140180406970752 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:29:26.426 T:140180406970752 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:29:27.234 T:140180406970752 NOTICE: ADDONS: Using repository repository.xbmc.org
13:29:27.242 T:140179805300480 NOTICE: PulseAudio: Opened device Default in pcm mode with Buffersize 150 ms
13:29:27.303 T:140180406970752 NOTICE: Checking resolution 15
13:29:27.446 T:140180406970752 ERROR: Failed to determine egl config for visual info
13:29:27.446 T:140180406970752 WARNING: Visual 0x28 of the window is not suitable, looking for another one...
13:29:27.446 T:140180406970752 NOTICE: Using visual 0x21

13:29:26.375 T:140180406970752 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanSuspend'
13:29:26.376 T:140180406970752 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanHibernate'
 

VikingVic

New member
Mar 25, 2014
16
0
0
More excerpts:

20:16:48.424 T:140187194333248 NOTICE: Starting Kodi (17.1 Git:20170320-nogitfound). Platform: Linux x86 64-bit
20:16:48.424 T:140187194333248 NOTICE: Using Release Kodi x64 build
20:16:48.424 T:140187194333248 NOTICE: Kodi compiled Mar 20 2017 by GCC 4.8.4 for Linux x86 64-bit version 3.13.11 (199947)
20:16:48.424 T:140187194333248 NOTICE: Running on Ubuntu 14.04.3 LTS, kernel: Linux x86 64-bit version 3.19.0-32-generic

20:16:51.807 T:140187194333248 ERROR: Failed to determine egl config for visual info
20:16:51.807 T:140187194333248 WARNING: Visual 0x28 of the window is not suitable, looking for another one...

20:17:15.747 T:140185156671232 ERROR: metahandler: Error connecting to TMDB: HTTP Error 401: Unauthorized
20:42:49.060 T:140185568278272 ERROR: Unable to find plugin
20:42:49.060 T:140187194333248 ERROR: GetDirectory - Error getting plugin://
20:42:49.060 T:140187194333248 ERROR: CGUIMediaWindow::GetDirectory(plugin://) failed
20:43:27.722 T:140186591692544 ERROR: GetDirectory - Error getting
20:46:35.137 T:140185208641280 ERROR: Previous line repeats 2 times.
20:46:35.138 T:140185208641280 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 500

Both log files using the appropriate Nvidia video drivers but also happening on Intel Graphics chips and ATI 5400 machines.
All machines using linux either 14.04 or 16.04. Major fubar since the Krypton update (17.0 or 17.1 which made it more unstable).
 

MiizAm

New member
Mar 24, 2017
4
0
0
Also having the same issue on my Android box...got a pop up said Indigo error and poof all of my streams are gone...every last one. I am fairly new to Kodi and have no idea how to even find logs let alone post them
 

VikingVic

New member
Mar 25, 2014
16
0
0
Been there done that over 10 times now.
Uninstalling, autoremove, purge, come back and reinstall after a reboot. even upgraded and cleaned up the linux kernals, same crashing.
For some reason it reaches out and fails to get a response.
Is it the internet? But then why the sigsegv segmentation fault?
And on more than one computer, different flavours of linux (16.04 and 14.04) All three types of video cards (intel, ATI, Nvidia), also with FRESH LINUX INSTALLS?
When I reach out to the fusion drive, bang I'm out and a sigsegv segmentation fault.
Is my ISP playing games on me?
I even changed the primary DNS I reach out to.
WTF?
 

crzen

New member
Aug 24, 2013
460
0
0
hey guys, I just installed kodi and indigo on a fresh mint 18.1 install.
I'm trying to duplicate the crash but its working here.
Is it doing this after you run the wizard or what?
I do know there is a problem with pyopenssl and the youtube addon which could be the problem.
See this thread All tvaddons broken on 64bit linux since 10/3/2017
Can you give me some more info an whats installed when it starts crashing?
 
Last edited:

VikingVic

New member
Mar 25, 2014
16
0
0
Hello and thanks.

It crashes randomly. Most often when Indigo or Ex**us is installed. And definitely with Pho*nix and SA*TS. Velo**ty, 1Ch**nel, doesn't matter, they all do it at various times.
Usually when one tries to install from the repository one sees failed to install due to a dependency and then the crashing begins. Sometimes it Json, sometimes other dependencies. But that does seem to be a factor. if something fails to install then you need to wipe out Kodi (purge it and auto remove it) and start from scratch. Works for an hour or day and then fails. inconsistent errors. the worst kind. will try to post some of the error logs but if indigo fails then there is no way to upload a log file.
Funny enough if just the KODI basic addons are just installed it works for a day and then crashes.
And yes the youtube addon is a must.

I've seen sigsegv segmentation faults, I've seen corrupted temp DB's (hence the basic LINUX crashes. Seems it signal a corrupted disk and I've JUST INSTALLED 2 NEW HDD and installed Linux Mint 64bit on both, one 18.1 and the other 17.3 FRESH, Cinnamon both).
My thinking is that for some reason the temporary DB's created by the addons are being corrupted and causing what looks like a HDD fault and kicking out KODI. Maybe in the swap space since it is intermittent.
I am not a developer or coder but have been reading the log files and trying to trace what they mean online.
I have also 6 machines with various hardware all running linux 64 bit (14.04 and 16.04 cinnamon flavours) and all are exhibiting the same crashing since March 10 (the Krypton 17.1 update date).


Thanks for the help ( and the forum ) and please let us know what you find.
VikingVic
 

crzen

New member
Aug 24, 2013
460
0
0
uninstall youtube for a test for a day or two and see if it still crashes.
if that stops it, look at that other thread I posted.
I know the pyopenssl and youtube will cause it to crash.
And thats with the youtube addon not running at the time.
it might be being used by other addons or somethng.
You just need to update three files if thats it.
its not kodi or the addons
 
Last edited:

VikingVic

New member
Mar 25, 2014
16
0
0
Can you post the codes to install each of them here please?

For python I know it is:

sudo apt install python-pip

The other two I am having some difficulty finding.

Thank you.
 

VikingVic

New member
Mar 25, 2014
16
0
0
Have this for the openssl


Extracting files from the downloaded package:

tar -xvzf openssl-1.0.1g.tar.gz

Now, enter the directory where the package is extracted.

cd openssl-1.0.1g

Configuring OpenSSL:

./config --prefix=/usr/local/openssl --openssldir=/usr/local/openssl

Replace "/usr/local/openssl" above with the directory path where you want to copy the files and folders. Note: check for any error message.
Compiling OpenSSL:

make

Note: check for any error message.
Installing OpenSSL:

As root (for privileges on destination directory), run the following.
With sudo,

sudo make install

Without sudo,

make install

Note: check for any error messages.

Thats it. OpenSSL has been successfully installed. You can run the version command to see if it worked or not.

/usr/local/openssl/bin/openssl version

Please let me know if this is correct.
 

crzen

New member
Aug 24, 2013
460
0
0
sudo pip install --upgrade pip
sudo pip install pyopenssl --upgrade
sudo pip install cryptography --upgrade

Thats all i had done after I installed pip from apt-get

oh im also running python 2.7.12
python -V
OpenSSL 1.0.2g 1 Mar 2016
 
Last edited:

VikingVic

New member
Mar 25, 2014
16
0
0
Thank you.

found out sudo pip install....does not work unless you do this first.....
sudo apt install python-pip

Says command pip not found.
So python needs to be installed first.

Will test it out and get back to you soon.

Thanks again.
 

VikingVic

New member
Mar 25, 2014
16
0
0
Sorry for being such a pest but here is my latest update.

In order had to run:

sudo apt install python-pip
sudo pip install --upgrade pip
sudo pip install setuptools
sudo pip install pyopenssl --upgrade
sudo pip install cryptography --upgrade

Only issue so far got an error on the last one.

build/temp.linux-x86_64-2.7/_openssl.c:12:24: fatal error: pyconfig.h: no such file or directory
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

Rolling back uninstall of cryptography

will try this on the other 3 machines and see what happens.
 

VikingVic

New member
Mar 25, 2014
16
0
0
Deeper into the rabbit hole we go.....

Just got this error.

SSL Warnings

urllib3 will issue several different warnings based on the level of certificate verification support. These warning indicate particular situations and can resolved in different ways.

InsecureRequestWarning
This happens when an request is made to an HTTPS URL without certificate verification enabled. Follow the certificate verification guide to resolve this warning.

InsecurePlatformWarning
This happens on Python 2 platforms that have an outdated ssl module. These older ssl modules can cause some insecure requests to succeed where they should fail and secure requests to fail where they should succeed. Follow the pyOpenSSL guide to resolve this warning.

SNIMissingWarning
This happens on Python 2 versions older than 2.7.9. These older versions lack SNI support. This can cause servers to present a certificate that the client thinks is invalid. Follow the pyOpenSSL guide to resolve this warning.

Not going our way is it easily....