Unable to connect to wifi on virgin media

supta

New member
Jan 7, 2014
1
0
0
Any help would be appreciated

Brand new box. Everything loads as should do ( I also have an apple tv xbmc as well so am familiar with some of the settings)

Go to the network settings to try and connect to my virgin media superhub and for some reason it shows 2 connections for the superhub. No matter how may resets of both the superhub and the Gbox.

Anyway, try to connect to the superhub (as with every other device I have, phone, ipad, laptop etc) it asks for the password. I input the password (same as usual) but nothing......... just does not connect

I have spend hours trying to figure out what I have missed, multiple resets, checked the password a dozen times. Every other device I have connects instantly except the gbox

ANY IDEAS BEFORE I GO MAD

Thanx in advance Garry
 

Tonts

New member
Sep 22, 2013
310
0
0
Sesame Street
MX2 fix is here,
http://matricom.net/wiki/MX2#WiFi
http://matricom.net/forum/index.php?topic=3786.0
Using Root Explorer go to data/misc/wifi

- Click and hold the OK button on wpa_supplicant file
- Click Delete And Confirm
- Go to Settings or SettingsMBox and turn on your Wifi
- Select your wireless network and enter your password

(You must have Root Access in order to get to this folder.
Please make sure your Superuser App is allowing all apps to have Root Access.
Go to All Apps, then Superuser, then on top click on the little dots and go into the settings of the Superuser App. Then set the permissions to automatically allow access.)

Question; (If I delete the wpa_supplicant file file on my box, will i never have a problem?)
Answer; No it will just rewrite it. It happens when the file gets corrupt.

The cause is apparently the "wpa_supplicant file" becoming corrupt, possibly when a lot of buffering has taken place or large file downloads are stopping the file being written correctly and causing the corruption.
(Apologies in advance if this is not the cause lol.)
WiFi
The wpa_supplicant file that needs to be deleted.

If your Wifi is turning on and off on it's own:

Using a Root Explorer (in this instance we are using ES File Explorer) go to data/misc/wifi. See above for using ES File Explorer.

Click and hold the OK button on wpa_supplicant file. (See picture to the right).
Click Delete And Confirm
Go to Settings or SettingsMBox and turn on your Wifi
Select your wireless network and enter your password

If the WiFi stops responding, there are two routes you can go:
Clear the Cache partition.
Reflash the box
Try the first option first! You can do this by the toothpick method with NO SD card inserted. Once at the recovery menu for the MX2, choose "Reset Cache Partition". This will flush the cache and should allow the user to maintain settings and jumpstart the WiFi.
 

tvro

New member
Aug 8, 2013
34
0
0
Canada
another way is to reload firmware and start over its a bug in the mx2's

reload firmware try to connect once connected go into xbmc load hub you are up and running