Unable to Install anything onto Kodi

smoball

New member
Apr 19, 2018
2
0
0
Hi All,

Been running Kodi Krypton successfully on my Sony Bravia tv since it was released.
Today all of my add ones stopped working.
I followed the instructions on this website and various others to solved the program.
Kept getting the error message
"Failed to install Add-on from zip file - The dependency version could not be satisfied"

I have tried multiple repositories, by entering them directly into the file manager by adding source, as well as to install from zip file off of a thumb drive.

None of this worked. I tried installing the URLsolver and this also did not work.
I tried clearing the cache, then the data and still nothing.

I completely uninstalled Kodi and redownloaded it, and still I am unable to install anything into Kodi.
This program is now bare empty and essentially useless.
I have run out of ideas of how to fix this issue.

Is anyone able to help me out?
 

smoball

New member
Apr 19, 2018
2
0
0
Thanks for that, but I have already googled, and tried a variety of things - hence the reason for posting this thread.
Found nothing helpful.
 

jaded

Member
Mar 20, 2014
34
0
6
Hi All,

Been running Kodi Krypton successfully on my Sony Bravia tv since it was released.
Today all of my add ones stopped working.
I followed the instructions on this website and various others to solved the program.
Kept getting the error message
"Failed to install Add-on from zip file - The dependency version could not be satisfied"

I have tried multiple repositories, by entering them directly into the file manager by adding source, as well as to install from zip file off of a thumb drive.

None of this worked. I tried installing the URLsolver and this also did not work.
I tried clearing the cache, then the data and still nothing.

I completely uninstalled Kodi and redownloaded it, and still I am unable to install anything into Kodi.
This program is now bare empty and essentially useless.
I have run out of ideas of how to fix this issue.

Is anyone able to help me out?
I had this problem last month. It was my ISP. Copy and paste this below into a command prompt running as an administrator.

ping mirrors.kodi.tv

If you have no lost packets then that's not your problem. If you do then contact your ISP. I don't know how you can add a VPN to a Sony Bravia TV but there are free ones like this for windows which confirmed that my ISP was blocking mirrors.kodi.tv which is what you need to connect to to install those missing dependencies.

https://windscribe.com/download

In my case after 10 frustrating days my ISP fixed the problem.