URLResolver and RealDebrid issues

Ambremont

New member
Sep 19, 2016
10
0
1
I've re-authorized URLResover 5.0.20 a number of times in the past few days to no avail. I still can't get RD links/sources in the 4 Kodi addons I use: UltraStream, vStream, ****** and *********. Anybody with the same issues?
 

Ambremont

New member
Sep 19, 2016
10
0
1
I will try Resolve URL. However according a March 17, 2018 article on this site, I was under the impression that it was no longer maintained by jsergio123.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,584
59
48
The Halls of Valhalla
URL Resolver is no longer maintained by jsergio, he now maintains Resolve URL while TVAddons now maintains URL Resolver for other legal addons.
 

NetworkGuy

New member
Feb 15, 2016
7
0
0
I'm having the SAME issue. I have a Real-Debrid account which has worked since last year. Something changed in the last several days (maybe up to a week back) - I now see all links being skipped until at the conclusion, it says "no stream available". I've tried several add-ons to see if it is add-on related (P l a c e n t a, Powder and E x o d u s). I see the same messages for any of them, so I guess it would NOT work for any other add-ons either though I have not confirmed with any others at this time.

Any idea what I can look at to fix my machine?
 
Last edited:

monty28428

New member
Jun 7, 2014
22
1
3
I'm having the SAME issue. I have a Real-Debrid account which has worked since last year. Something changed in the last several days (maybe up to a week back) - I now see all links being skipped until at the conclusion, it says "no stream available". I've tried several add-ons to see if it is add-on related (P l a c e n t a, Powder and E x o d u s). I see the same messages for any of them, so I guess it would NOT work for any other add-ons either though I have not confirmed with any others at this time.

Any idea what I can look at to fix my machine?
First login to real debrid's web site and make sure your account is still Premium -- if not renew service.

If that is true then activate real debrid with ResolverURL and URLResover (they are different … Two of the ones you listed use ResolverURL -- no idea on the powder puff).
 

NetworkGuy

New member
Feb 15, 2016
7
0
0
First login to real debrid's web site and make sure your account is still Premium -- if not renew service.

If that is true then activate real debrid with ResolverURL and URLResover (they are different … Two of the ones you listed use ResolverURL -- no idea on the powder puff).
To further monty28428's post, reset the function cache of both Resolve URL and URL Resolver.
Thanks monty and RavRob! I did all of that. I had recently renewed my RD account and it shows premium until December of 2018. And I reactivated both ResolverURL and URLResolver. Unfortunately I still see the same behavior where it goes through every RD stream until I finally get the dreaded "no stream available" message. I'm stumped!
 

NetworkGuy

New member
Feb 15, 2016
7
0
0
First login to real debrid's web site and make sure your account is still Premium -- if not renew service.

If that is true then activate real debrid with ResolverURL and URLResover (they are different … Two of the ones you listed use ResolverURL -- no idea on the powder puff).
To further monty28428's post, reset the function cache of both Resolve URL and URL Resolver.
Did you alsoreset the function cache when you reauthorized read debrid again?
I did not do that, but I'll do that for both add-ons today and see if that helps. Thanks for that suggestion!
 

billce

New member
Jul 13, 2016
87
0
0
I hope this is the right place for this question. There is no URL resolver in dependencies. Resolve URL is there, but from what I read, they are different. How can URL resolver be installed? Manually? Or what? As it is, nothing can be done to it because it's not there.
Thanks for any help.
P.S. I've looked for the answer to this and no one seems to know. Most of them talk about TVaddons repo. I've tried all the suggestions and none work.
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,584
59
48
The Halls of Valhalla
If you cannot find it, that is because it was never installed as a dependency for any addons. It only gets installed when needed. Even if you install it manually, it will show as an orpan and will be of no use to any of your addons.
 

billce

New member
Jul 13, 2016
87
0
0
Hi Rav,
Sorry. I thought I put it in the wrong place.
Then what I read about it being installed automatically when Indigo is installed is wrong. If the tvaddons' automatic install of the best addons for Kodi are installed, there's bound to be an addon that uses it. Right?
Anyway thanks for the help.
Bill
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,584
59
48
The Halls of Valhalla
Not sure which of TVA's addons you have installed. Theire are certainly some addons that still use URL Resolver but many moved to Resolve URL. If you want to install it, you can go to Kodi settings>Addons>Install from Zip>Fusion>\Kodi-Scripts>script.module.urlresolver-x.x.xx.zip

Then go to your manage dependencies and see if it is orphan or not. I would think it will be orphan but you will have it installed.
 

billce

New member
Jul 13, 2016
87
0
0
It doesn't install. Just sits there. No matter if resolve url does the job.
The important thing is that no stream available must not be caused by anything to do with url resolver. Really frustrating.
I'll have to keep looking for a solution. A year ago I was able to stream everything. Now nothing.
Thanks Rav
 

JNRW

New member
Oct 13, 2014
151
1
0
Another thing to try is to reinstall Kodi over your existing set up. If there is anything wrong or missing within Kodi this operation will sort it. At worst it is a few wasted minutes.
 

billce

New member
Jul 13, 2016
87
0
0
I won't list the addons because there's infringers in the list. Suffice to say that the no stream available problem happens with every addon. I even tried BlueStacks. Same thing "no links found". Maybe there's a clue in the fact that this happens in every addon on any player?
BTW, per your instructions I installed URL resolver.
 
Last edited:

billce

New member
Jul 13, 2016
87
0
0
JNRW,
Reinstalling over existing Kodi made no difference. Still "no stream avail".
If anybody comes up with a solution to this, his name should be put in some hall of fame somewhere!
 

JNRW

New member
Oct 13, 2014
151
1
0
Are you sure your add-ons are enabled? Are the two items in VideoPlayer InputStream enabled?