Bug URLResolver fails with real debrid

zmanfarlee

New member
May 10, 2015
7
0
0
well its only been like 5 hours of me trying.... I cant get Real Debrid to Authorize. I keep getting a URL resolver error. Got a little better when I reinstalled kodi and tried to do real debrid first but to no avail. ANY GENIUSES PLEASE HELP!

https://paste.ubuntu.com/25914487/

That's the log thingy... I think it's at line 759. please help. Ubuntu 16.04
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,576
59
48
The Halls of Valhalla
Do you have the latest version installed? Go to Kodi settings>Addons>Install from zip>Fusion>Something something Scripts and select URL Resolver.
Now in an addon which uses URL resolver, go to Tools an enable RD in there. You will likely have to enable the use of RD and also enter your credentials. So a couple of places need to be edited.
You will also need to allow the device in Real-Debrid.com/Device so the device is allowed at the RD site.
 

zmanfarlee

New member
May 10, 2015
7
0
0
Do you have the latest version installed? Go to Kodi settings>Addons>Install from zip>Fusion>Something something Scripts and select URL Resolver.
Now in an addon which uses URL resolver, go to Tools an enable RD in there. You will likely have to enable the use of RD and also enter your credentials. So a couple of places need to be edited.
You will also need to allow the device in Real-Debrid.com/Device so the device is allowed at the RD site.
I think I dont have fusion.... just used smash repo. I will try to to do it that way when I get home but I had the latest version. I'll update tonight.
 

zmanfarlee

New member
May 10, 2015
7
0
0
Do you have the latest version installed? Go to Kodi settings>Addons>Install from zip>Fusion>Something something Scripts and select URL Resolver.
Now in an addon which uses URL resolver, go to Tools an enable RD in there. You will likely have to enable the use of RD and also enter your credentials. So a couple of places need to be edited.
You will also need to allow the device in Real-Debrid.com/Device so the device is allowed at the RD site.
Maybe its because I didnt install fusion from the new .co website first. Fingers Crossed
 

zmanfarlee

New member
May 10, 2015
7
0
0
Hope this works for you.
Got it working. Did a fresh install and set up ******** and real debrid first before messing with VPN and everything else. Also authorized through my phone instead of the same computer.

Shotgun approach did it
 

bawood77

New member
Jun 4, 2017
3
0
0
Bumping because i got the same issue out of nowhere today and tried manually updating (was already updated tho) and restarting kodi and the device but still no luck, im not even trying vpn or anything else, just trying to reauth my rd account and keep getting urlresolver error. Yes i run fusion and have everything updated too. Please help!

My logs: https://imgur.com/a/47pY9
 

RavRob

Moderator
Staff member
Nov 21, 2012
6,576
59
48
The Halls of Valhalla
Sorry, no one can help with that log. To post a proper log, have a look at my signature.
As for RD, it is not simply a matter of re-authorizing. Go to the addon settings, in the URL Resolver, navigate to RD settings and set your priority to 90, enable "automatically select primary link", reset authorization, restart Kodi and go back to re-authorize RD. That fixed it for me yesterday.

Not sure if it is caused by an update of URL Resolver or if it is a RD issue. Also, some addons moved to a fork of URL Resolver so it may not be a URL Resolver issue at all.