Urlresolver, Real-Debrid and Hugefile issues

Kjxn

New member
May 11, 2012
564
0
0
I have a couple of different issues going on that I've been trying to resolve over the last few days. I have the latest 2.09 urlresolver, running Frodo on all iDevices. On my iPad, iPhone, Atv1 & Atv2 and RaspPi, if I go in to an addon and choose a title to play, Hugefiles autoplays. When I stop the movie (or tv episode), from playing, it puts me in a play loop, stop/starts, stop/starts. When I disable or set the priority of hugefiles to resolve after real-debrid (110), then I don't get any real-debrid sources. e.g., netload.in, rapidgator, etc. When I tail the logs on the RaspPi, I see that Hugefile is trying to download my movie. I have been searching around, but I don't see anyone else that seems to be reporting this issue. Looking beyond the Hugefiles issue, I'm not seeing any real-debrid sources in any of the addons that have resolver and I'm seeing a lot of real-debrid errors in my log.

I have manually installed urlresolver 2.09, removed urlresover and then uninstalled 1Ch**nel and reinstalled. Checked for updates on xbmc.org repo. Using all the options, I still don't get real-debrid sources. I do have 191 days left on my premium acct. I haven't changed my resolver login settings and made sure I could login to real-debrid.com with current credentials. I don't appear to be on a banlist with my Mac addy as I can login to real-debrid.com from PC on the same network. I have removed my database .db's. I have posted a log, hoping someone can see something I'm not. http://pastebin.com/RcCkt7VH

In my log, I used Rele**BB for an example, but I get the same results with any of the resolver addons I have installed. In the log, I played a movie, stopped it, went in to MashUp's addon, the stream started again, stopped it, and while MashUps links were resolving, the movie started again.

Any help or direction would be greatly appreciated.
 

Kjxn

New member
May 11, 2012
564
0
0
The real-debrid resolver is broken, dont know about the other
Thanks for replying so quick! The real-debrid resolver is broken globally, or just mine? I'll deal with the Hugefile issue, I can fix that myself :)
 

Kjxn

New member
May 11, 2012
564
0
0
Thanks Jason! I'll keep plugging away at it, as long as I know it isn't just me, I'll work on a temp fix.
 

jas0npc

Banned
May 5, 2012
2,449
0
0
UK
try this onpen up the realdebrid resolver.py file from XBMC\addons\script.module.urlresolver\lib\urlresolver\plugins
and replace the def valid_url(self, url, host): with this
Code:
def valid_url(self, url, host):

        if self.get_setting('login') == 'false':
            return False
        print 'in valid_url %s : %s' % (url, host)
        tmp = re.compile('//(.+?)/').findall(url)
        domain = ''
        if len(tmp) > 0 :
            domain = tmp[0].replace('www.', '')
            if 'megashares' in domain:
                domain = 'megashares.com'
            elif 'megashare' in domain:
                domain = 'megashare.com'
            print 'domain is %s ' % domain
        #if (domain in self.get_all_hosters()) or (len(host) > 0 and host in self.get_all_hosters()):
        return True
        #else:
         #   return False
 

Kjxn

New member
May 11, 2012
564
0
0
try this onpen up the realdebrid resolver.py file from XBMC\addons\script.module.urlresolver\lib\urlresolver\plugins
and replace the def valid_url(self, url, host): with this
Code:
def valid_url(self, url, host):

        if self.get_setting('login') == 'false':
            return False
        print 'in valid_url %s : %s' % (url, host)
        tmp = re.compile('//(.+?)/').findall(url)
        domain = ''
        if len(tmp) > 0 :
            domain = tmp[0].replace('www.', '')
            if 'megashares' in domain:
                domain = 'megashares.com'
            elif 'megashare' in domain:
                domain = 'megashare.com'
            print 'domain is %s ' % domain
        #if (domain in self.get_all_hosters()) or (len(host) > 0 and host in self.get_all_hosters()):
        return True
        #else:
         #   return False
Yep, that worked!!! My HERO!!! THANK YOU
 

baci

New member
May 13, 2012
1,474
0
0
Toronto, Canada
For the life of me I can't find this on my appletv2? Would someone be kind enough to guide me? XBMC\addons\script.module.urlresolver\lib\urlresol ver\plugins
 

jas0npc

Banned
May 5, 2012
2,449
0
0
UK
For the life of me I can't find this on my appletv2? Would someone be kind enough to guide me? XBMC\addons\script.module.urlresolver\lib\urlresol ver\plugins

/private/var/mobile/Library/Preferences/XBMC/addons/script.module.urlresolver/lib/urlresolver/plugins