Release USTVnow Plus Official Release Thread

LLine

New member
Feb 6, 2016
8
0
0
I'm still having a prob with both the USTVnow and the USTVnow Plus addons on my MXQ Box. When I click on a channel all it does is sits there and spins saying working. Locks up the box and only way out is to hit the boxes home button. Was working good till yesterday afternoon. I was watching and all of a sudden it went back to the channel list and after that I haven't been able to get it to work. I made sure both apps were updated this morning after I seen you fixed it and still it would just sit and spin. I appreciate all you guys do thank you! Sure hope you can help This is for the Live Tv and I'm using Free Account. I just tried uninstalling the apps and Installing them again and still it sits and spins working.
 
Last edited:

mredrup

New member
Sep 7, 2013
3
0
0
I'm still having a prob with both the USTVnow and the USTVnow Pls addons on my MXQ Box. When I click on a channel all it does is sits there and spins saying working. Locks up the box and only way out is to hit the boxes home button. Was working good till yesterday afternoon. I was watching and all of a sudden it went back to the channel list and after that I haven't been able to get it to work. I made sure both apps were updated this morning after I seen you fixed it and still it would just sit and spin. I appreciate all you guys do thank you! Sure hope you can help This is for the Live Tv and I'm using Free Account. I just tried uninstalling the apps and Istalling them again and still it sits and spins working.
I am having this same issue. It never gets past working when selecting a channel from the list. Mine is a free account.
 

arecibo12

New member
Feb 6, 2016
1
0
0
I only recently started using the USTVNow app. Yesterday morning when I logged into it all of the paid channels appeared. I decided to try and adjust the video quality to HD and to my happy surprise I was able to watch HD before heading off to work. Yesterday afternoon when I got home the app was replaced with the USTVNow Plus app and all the settings were once again returned to what is supposed to come with the free version. I redownloaded the original app, told it I had a paid subscription (even though I didn't) and that's where my problems began. From that point forward anytime I try to run the USTVNow app it gives me the spinning 'working' message but it actually just hard crashes Kodi. I've removed the old app, cleared kodi cache, removed the new app, reinstalled the new app, reset the default settings and reinputted my login data. Everything comes back with the same result. I even uninstalled the app, exited out of Kodi and went in the addon directory in Windows to see if it was still in there (it wasn't), ran CCleaner, but still get the same result.

Anyway, based on some other things I've seen apparently a USTVNow free account gets treated like a paid account after 45 days? That would explain why my channels changed all the sudden because that is about the length of time I've been using this app.

It's a great app, but like I said, now anytime I try to run a live stream Kodi crashes with a spinning 'working'. I've uploaded my log file: http://xbmclogs.com/pdnlx16mh.

Your help is greatly appreciated.
 

Arcana XV

New member
Feb 6, 2016
20
0
0
I'm having the same problem on AFTV box as the users above. When I click on a channel it just spins forever and freezes the Kodi app. I have to hit the home button and force close the app from the app manager settings. Does anyone know if this issue is only happening for free accounts? I've been thinking of getting a paid account, but if I can't watch it on my TV I'm not gonna bother. I'll just make do with any old working iptv app.

Thanx for your help.
 

Trespasser

Member
Nov 2, 2015
58
0
6
mhancoc7,
Can you provide a link to your new repo for 14.0.9? I have the plugin but I'd like to have the repo file as well.

BTW, I posted a message to you over at Kodi.tv, but then I found you here. :). Also, your new version works great.

Thanks for taking over this project.

Bob
 

Zendall

New member
Nov 19, 2015
34
0
0
All channels working fine on my AFTV box. At first I was getting a bit of stutter in both audio & video. I rebooted my box & modem/router & now it works like before. I can't help but notice the picture quality isn't as good. A bit blurry & some pixels. I'll take what I can get. BIG THANKS!!! Haven't checked my stick yet but I don't expect any issues.

For you who use AFTV, it really does pay to reboot your device a couple times a week. Seems to clear issues up including lag in Kodi, lockups in Hulu, "can't play this video" messages in Netflix. I reboot my modem w/built-in router when I reboot the AFTV box. It really helps.
 

mredrup

New member
Sep 7, 2013
3
0
0
I guess if it can't be used with free accounts any longer it's time to delete the addon. It was nice while it lasted though and thanks for providing it.
 

mainlinetradng

New member
Mar 20, 2015
5
0
0
Hi Thanks for your work on the addon I have it working now. In previous versions it would link to the FTVGuide will this be possible with this version.
 

Zendall

New member
Nov 19, 2015
34
0
0
I guess if it can't be used with free accounts any longer it's time to delete the addon. It was nice while it lasted though and thanks for providing it.
I have a free account & today it's working fine. The developer has corrected an issue that prevented free accounts from working.
 

amoreno1093

New member
Jun 24, 2015
11
0
0
First off, big thanks for this add-on! I have a couple questions though. 1) on the website, I can watch the channels in HD with a free account. So why is the green account limited to 400kbps in the add-on? 2) I use Kodi on two boxes and one computer in my house, and I have set up boxes for three family members. If I upgrade to a paid USTVnow account, can my account be used on all of our devices?
 

Arcana XV

New member
Feb 6, 2016
20
0
0
Looks like everything is back to normal for me too. Yay! Thanks so much for the work you do on this addon, mhancoc7!
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
I'm still having a prob with both the USTVnow and the USTVnow Plus addons on my MXQ Box. When I click on a channel all it does is sits there and spins saying working. Locks up the box and only way out is to hit the boxes home button. Was working good till yesterday afternoon. I was watching and all of a sudden it went back to the channel list and after that I haven't been able to get it to work. I made sure both apps were updated this morning after I seen you fixed it and still it would just sit and spin. I appreciate all you guys do thank you! Sure hope you can help This is for the Live Tv and I'm using Free Account. I just tried uninstalling the apps and Installing them again and still it sits and spins working.
This still sounds like the issues that I fixed with the last release. Are you using the Official Version v14.0.9? If so can you please provide a log file so I can troubleshoot the issue.

Thanks
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
I only recently started using the USTVNow app. Yesterday morning when I logged into it all of the paid channels appeared. I decided to try and adjust the video quality to HD and to my happy surprise I was able to watch HD before heading off to work. Yesterday afternoon when I got home the app was replaced with the USTVNow Plus app and all the settings were once again returned to what is supposed to come with the free version. I redownloaded the original app, told it I had a paid subscription (even though I didn't) and that's where my problems began. From that point forward anytime I try to run the USTVNow app it gives me the spinning 'working' message but it actually just hard crashes Kodi. I've removed the old app, cleared kodi cache, removed the new app, reinstalled the new app, reset the default settings and reinputted my login data. Everything comes back with the same result. I even uninstalled the app, exited out of Kodi and went in the addon directory in Windows to see if it was still in there (it wasn't), ran CCleaner, but still get the same result.

Anyway, based on some other things I've seen apparently a USTVNow free account gets treated like a paid account after 45 days? That would explain why my channels changed all the sudden because that is about the length of time I've been using this app.

It's a great app, but like I said, now anytime I try to run a live stream Kodi crashes with a spinning 'working'. I've uploaded my log file: http://xbmclogs.com/pdnlx16mh.

Your help is greatly appreciated.
H
The USTVnow Plus addon has replaced the USTVnow Live addon. I have taken it on to maintain. It is built utilizing the USTVnow API fully. This is why you no longer have the option to tell the addon if you have a Paid or Free account. Since the addon actually checks your account details. This does mean that you can't set things to HD on a Free account. I am working on a way to determine the age of an account so those Free account can get their HD within the first 45 days. However, for now it is set to 400kbps for Free accounts.

The fact that you are getting the spinning and no streams sounds like an issue that was caused by a change in the USTVnow system just after the release. Be sure that you are running v14.0.9 of the addon as this has the fix for Free Accounts.

I took a look at your log and couldn't see anything of use in it. Be sure that you have debugging turned on for the logs.

I would like to know if you are still having issues on v14.0.9 since that should be fixed.

Thanks
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
mhancoc7,
Can you provide a link to your new repo for 14.0.9? I have the plugin but I'd like to have the repo file as well.

BTW, I posted a message to you over at Kodi.tv, but then I found you here. :). Also, your new version works great.

Thanks for taking over this project.

Bob
The latest version is in the TVaddons Repo. It is also available in the Addon Installer.

https://www.tvaddons.co/install-addons-kodi/

I saw your post over at Kodi.tv. I just haven't had a chance to get caught up. :)

I am glad that you like the version that I have put together.

Thanks!
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
All channels working fine on my AFTV box. At first I was getting a bit of stutter in both audio & video. I rebooted my box & modem/router & now it works like before. I can't help but notice the picture quality isn't as good. A bit blurry & some pixels. I'll take what I can get. BIG THANKS!!! Haven't checked my stick yet but I don't expect any issues.

For you who use AFTV, it really does pay to reboot your device a couple times a week. Seems to clear issues up including lag in Kodi, lockups in Hulu, "can't play this video" messages in Netflix. I reboot my modem w/built-in router when I reboot the AFTV box. It really helps.
Glad to hear that it is working for you. As for the quality issues. If you are on a Free account I have limited the stream quality to 400kbps. I am working on a way to determine the age of an account so that new Free accounts can get HD for the first 45 days. Other than that this addon is streaming in the same way as previous version. The big differences are in how the data needed to build the streams is gathered which shouldn't affect the quality.

Thanks
 

mhancoc7

m7
Staff member
Aug 2, 2015
1,742
12
38
m7kodi.dev
I guess if it can't be used with free accounts any longer it's time to delete the addon. It was nice while it lasted though and thanks for providing it.
The latest version v14.0.9 should be working for all account types now. If you are still having issues on that version please post a debug log and I will trouble shoot it.

Thanks