VPN help needed router

wangoriley

New member
Nov 27, 2013
16
0
0
I'm trying to run a VPN through a d-link router setup with dd-wrt
I've followed the instructions on client support from privateinternetaccess but still can load up channel 1 or many of the other blocked sites in the uk
I've connected to the internet through dd-wrt on my apple box but no luck in viewing

Any advice would be great

Thanks
 

Flapster

New member
Nov 13, 2013
400
0
0
The Black Country, UK
I have never done this kind of set up but first what server are you using from PIA on your router? If you are using a UK one it still won't work and you would need to set it up to somewhere else. I have found the Netherlands to be the best for me nl.privateinternetaccess.com in settings.
 

wangoriley

New member
Nov 27, 2013
16
0
0
Hi Flapster, thanks for the quick response
I just changed the address to nl.privateinternetaccess.com in settings but theres still no access to Channel 1 or any of the other blocked UK add ons
I cant help but think there is something simple im missing

When trying step 8 I loose my internet totaly 8. If these steps do not work, please setup PPTP in the WAN section instead.

This is what im following
DD-WRT PPTP VPN Setup DD-WRT: VPN PPTP Setup
Ensure you have generated a Username and Password as per our GENERATING A PASSWORD FOR PPTP/L2TP/SOCKS guide.
In DD-WRT, access the VPN tab found under the Services section.
Enable the PPTP Client.
Set the Server IP or DNS Name to us-east.privateinternetaccess.com [*].
Set the MPPE Encryption to mppe required,no40,no56,stateless.
Enable NAT.
Enter your User name and Password.
If these steps do not work, please setup PPTP in the WAN section instead.
 

coltceavers

New member
Jan 14, 2014
5
0
0
Did you ever get this sorted Wagonriley? I'm in the same position with my linksys DD-WRT router. There seems to be options missing on this firmware revision for what PIA want me to do so I'm going to look at upgrading the firmware if possible.
 

coltceavers

New member
Jan 14, 2014
5
0
0
Ok, after a lot of reading and re-flashing my router firmware many times I have sorted out the problems and connected to the Privateinternetaccess VPN with my DD-WRT Router with the OpenVPN setup.
I had the same issues as wagonriley above, but on a different router. There should be a similar firmware revision for the D-Link router.

My router is a Linksys WRT54G Version 2 router

Firstly I reflashed the firmware of my router with one suggested on the Strong VPN web site.
for my V2 Router the firmware is DD-WRT (build 18777) V24-sp2 Dated 3/19/12 vpn

IT IS IMPORTANT TO USE THE CORRECT FIRMWARE VERSION FOR THE V2 ROUTER, WRONG FIRMWARE MAY BRICK YOUR ROUTER!

secondly i found and followed a tutorial from the privateinternetaccess forums. (User P666666) linked below


https://www.privateinternetaccess.com/forum/index.php?p=/discussion/comment/10980#Comment_10980

This worked perfectly first time for me, I hope it helps someone else out.

colt..
 
Last edited:

streamsfine

New member
Jan 16, 2014
14
0
0
Hi Flapster, thanks for the quick response
I just changed the address to nl.privateinternetaccess.com in settings but theres still no access to Channel 1 or any of the other blocked UK add ons
I cant help but think there is something simple im missing

When trying step 8 I loose my internet totaly 8. If these steps do not work, please setup PPTP in the WAN section instead.

This is what im following
DD-WRT PPTP VPN Setup DD-WRT: VPN PPTP Setup
Ensure you have generated a Username and Password as per our GENERATING A PASSWORD FOR PPTP/L2TP/SOCKS guide.
In DD-WRT, access the VPN tab found under the Services section.
Enable the PPTP Client.
Set the Server IP or DNS Name to us-east.privateinternetaccess.com [*].
Set the MPPE Encryption to mppe required,no40,no56,stateless.
Enable NAT.
Enter your User name and Password.
If these steps do not work, please setup PPTP in the WAN section instead.
If you have dd-wrt, why don't you set up openvpn? It's much more scure than L2TP and others. Instructions are also clear in PIA for it. Also make sure you check that it's working by looking up your IP address. You can use speedtest.net.
 

wangoriley

New member
Nov 27, 2013
16
0
0
Alas still no luck for me
Ive tried re flashing my router
tried following the instructions above from User P666666
Im wondering if I'm getting the commands right or not
Im changing the following only Red
Ove left all other commands as seen below and tried changing the servers address for another (nl.privateinternetaccess.com)

#!/bin/sh

USERNAME="Your_PIA_Username"
PASSWORD="Your_PIA_Password"
PROTOCOL="udp"
# Add - delete - edit servers between ##BB## and ##EE##
REMOTE_SERVERS="
##BB##
# US - WEST
remote us-west.privateinternetaccess.com 1194
##EE##
"

#### DO NOT CHANGE below this line unless you know exactly what you're doing ####
 

bigdogeh

New member
May 6, 2012
380
0
0
not really sure but maybe try replacing in brackets
your_PIA_Username
to
username
in brackets

the same with password

may need to get rid of the comments also, but i'm just guessing...


so it would look something like this

#!/bin/sh

USERNAME="Username"
PASSWORD="Password"
PROTOCOL="udp"
# Add - delete - edit servers between ##BB## and ##EE##
REMOTE_SERVERS="
##BB##
# US - WEST
remote us-west.privateinternetaccess.com 1194
##EE##
"

or this maybe


#!/bin/sh

USERNAME=Username
PASSWORD=Password
PROTOCOL=udp
# Add - delete - edit servers between ##BB## and ##EE##

##BB##
# US - WEST
REMOTE_SERVERS=remote us-west.privateinternetaccess.com 1194
##EE##
"

or even this..

#!/bin/sh

USERNAME="Username"
PASSWORD="Password"
PROTOCOL="udp"
# Add - delete - edit servers between ##BB## and ##EE##

##BB##
# US - WEST
"REMOTE_SERVERS=remote us-west.privateinternetaccess.com 1194"
##EE##
"

i'm just kinda guessing though...
 

coltceavers

New member
Jan 14, 2014
5
0
0
You need to get rid of the " your PIA" bit too

It should look like this

#!/bin/sh

USERNAME="Username"
PASSWORD="Password"
PROTOCOL="udp"
# Add - delete - edit servers between ##BB## and ##EE##
REMOTE_SERVERS="
##BB##
# US - WEST
remote us-west.privateinternetaccess.com 1194
##EE##
"

#### DO NOT CHANGE below this line unless you know exactly what you're doing ####

Obviously the usrename/password text is replaced by yours
Also below the line where you have finished above (#### DO NOT CHANGE etc...), your certificate in formation should be present